summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2020-02-08 04:23:15 +0100
committerSeverin Glöckner2020-02-08 04:23:15 +0100
commite6880fc5eba971dbe9440ebb39aa3dbfabc77d34 (patch)
tree0cb0c9a1a5928fd4182269b93b1bd8e29153c682
downloadaur-e6880fc5eba971dbe9440ebb39aa3dbfabc77d34.tar.gz
inital commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12e8dc6f202d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml-graphics
+ pkgdesc = Graphics library from OCaml
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://github.com/ocaml/graphics
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = dune
+ depends = ocaml>=4.0.9
+ options = !strip
+ source = https://github.com/ocaml/graphics/archive/5.0.0.tar.gz
+ sha256sums = 07f5861381f85c2f2c0611a86f483807ce43195959c40963028dafaa3abf33ab
+
+pkgname = ocaml-graphics
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4ba41db659b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+
+# Quoting the release notes of ocaml 4.0.9
+# »The graphics library was moved out of the compiler distribution.«
+# This package contains it.
+
+# v5.1.0 requires dune 2.0 to be in the Arch repository
+pkgname=ocaml-graphics
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="Graphics library from OCaml"
+arch=('x86_64')
+url="https://github.com/ocaml/graphics"
+license=('LGPL2.1')
+depends=('ocaml>=4.0.9')
+makedepends=('dune')
+source=("https://github.com/ocaml/graphics/archive/${pkgver}.tar.gz")
+sha256sums=('07f5861381f85c2f2c0611a86f483807ce43195959c40963028dafaa3abf33ab')
+options=(!strip)
+
+build() {
+ cd "${srcdir}/graphics-${pkgver}"
+
+ dune build -p graphics
+}
+
+
+package() {
+ cd "${srcdir}/graphics-${pkgver}"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+
+ # there's nothing useful inside
+ rm -r "${pkgdir}/usr/doc/"
+
+ install -Dm644 "$srcdir"/graphics-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # unfortunately, the files won't be found in the subfolder. Linking them
+ cd "${pkgdir}/usr/lib/ocaml/"
+
+ for file in graphics/graphics*
+ do
+ ln -s graphics/$(basename "$file") $(basename "$file")
+ done
+}
+