summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 13:39:27 +0200
committerJ5lx2015-10-10 13:39:27 +0200
commit0fcc343cd1d1e1f5423da3312146980ad391cf79 (patch)
tree89f5fecf06f72a4b0ac3b19154046a3f3fa3fc91
downloadaur-0fcc343cd1d1e1f5423da3312146980ad391cf79.tar.gz
0.2.1-1: Initial package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c54289231a6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ocaml-gstreamer
+ pkgdesc = OCaml bindings for the GStreamer multimedia framework
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-gstreamer
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = gstreamer
+ depends = gst-plugins-base
+ options = !strip
+ source = https://github.com/savonet/ocaml-gstreamer/releases/download/0.2.1/ocaml-gstreamer-0.2.1.tar.gz
+ md5sums = f450f7525df87069f1425c9b2d49a49e
+
+pkgname = ocaml-gstreamer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4fa5f221b87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-gstreamer
+pkgver=0.2.1
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings for the GStreamer multimedia framework")
+url="https://github.com/savonet/ocaml-gstreamer"
+depends=('ocaml' 'gstreamer' 'gst-plugins-base')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-gstreamer/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('f450f7525df87069f1425c9b2d49a49e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}