summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:07:41 +0100
committerDaniel Peukert2024-01-28 00:07:41 +0100
commitf8992efbb5a0b4da4f94b4349af9727838159f08 (patch)
tree95f0904ef5a72c2e08cbe5ac588944d383e2e464
parent9c1675bede7989a0767b37a029705d01d70165ec (diff)
downloadaur-f8992efbb5a0b4da4f94b4349af9727838159f08.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f0b3d701bfc..0b395830c31a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = ocaml-iter
url = https://github.com/c-cube/iter
arch = x86_64
arch = aarch64
- license = BSD
+ license = BSD-2-Clause
checkdepends = ocaml-mdx>=1.3.0
checkdepends = ocaml-ounit
checkdepends = ocaml-qcheck
diff --git a/.gitignore b/.gitignore
index 004b0a3a8706..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
# which causes the gitignore file to apply to them too, which breaks some builds
-# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
/*.tar
/*.tar.*
/*.rpm
diff --git a/PKGBUILD b/PKGBUILD
index c10b8d4840d6..184d9da7c3c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgrel='1'
pkgdesc='Simple iterator abstract datatype for OCaml'
arch=('x86_64' 'aarch64')
url="https://github.com/c-cube/$_projectname"
-license=('BSD')
+license=('BSD-2-Clause')
depends=('ocaml>=4.08.0')
makedepends=('dune>=2.0.0')
checkdepends=('ocaml-mdx>=1.3.0' 'ocaml-ounit' 'ocaml-qcheck')
@@ -37,5 +37,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/BSD-2-Clause"
}