summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2023-02-12 11:14:03 -0500
committerSean Anderson2023-02-12 11:14:03 -0500
commit8e3107799ced32b6262b1db0eaf2a6dee3f0a998 (patch)
treeff8e4e2994a9107b5405443ac3cbc76decd8c37e
parent8f9c6d287455ffeb65b375dbfe9932980494e832 (diff)
downloadaur-8e3107799ced32b6262b1db0eaf2a6dee3f0a998.tar.gz
3.2.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2feadd00e27..c3d9a9f122f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-javalib
pkgdesc = Parses Java .class files into OCaml data structures
- pkgver = 3.2.1
+ pkgver = 3.2.2
pkgrel = 4
url = https://github.com/javalib-team/javalib/
arch = i686
@@ -9,11 +9,10 @@ pkgbase = ocaml-javalib
makedepends = ocaml-findlib
depends = ocaml>=4.0.0
depends = ocaml-extlib>=1.5.1
- depends = ocaml-zip>=1.04
+ depends = ocaml-camlzip>=1.04
depends = zlib
options = !strip
- source = https://github.com/javalib-team/javalib/archive/v3.2.1.tar.gz
- md5sums = 0970ddb7c418f6b16184a329e49ba31c
+ source = https://github.com/javalib-team/javalib/archive/3.2.2.tar.gz
+ md5sums = 90174a2297d43891ee7ebaaf7d29b87e
pkgname = ocaml-javalib
-
diff --git a/PKGBUILD b/PKGBUILD
index f20cd4dde10d..9127c4c9adf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Sean Anderson <seanga2@gmail.com>
_oname='javalib'
pkgname=ocaml-$_oname
-pkgver=3.2.1
+pkgver=3.2.2
pkgrel=4
pkgdesc="Parses Java .class files into OCaml data structures"
arch=('i686' 'x86_64')
url="https://github.com/javalib-team/javalib/"
license=('LGPL2')
-depends=('ocaml>=4.0.0' 'ocaml-extlib>=1.5.1' 'ocaml-zip>=1.04' 'zlib')
+depends=('ocaml>=4.0.0' 'ocaml-extlib>=1.5.1' 'ocaml-camlzip>=1.04' 'zlib')
makedepends=('ocaml-findlib')
options=(!strip)
changelog=
-source=("https://github.com/javalib-team/$_oname/archive/v$pkgver.tar.gz")
-md5sums=('0970ddb7c418f6b16184a329e49ba31c')
+source=("https://github.com/javalib-team/$_oname/archive/$pkgver.tar.gz")
+md5sums=('90174a2297d43891ee7ebaaf7d29b87e')
prepare() {
cd "$_oname-$pkgver"