summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2023-04-01 11:59:04 +0200
committerAntonio Rojas2023-04-01 11:59:04 +0200
commit1e09208ec70ba50d0629da0b93a785e8cc75a9b2 (patch)
treefa42c9558c3f4e59b86baf18d83a7fec0d2230bf
parent24f881e64289b92d20bf959d11680311348ed5dc (diff)
downloadaur-1e09208ec70ba50d0629da0b93a785e8cc75a9b2.tar.gz
Spring cleanup
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 30 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72e5d27c59e5..ea06f8b4f253 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = ocaml-lablgl
pkgdesc = OCaml interface to OpenGL
- pkgver = 1.05
- pkgrel = 4
- url = https://forge.ocamlcore.org/projects/lablgl/
- arch = i686
+ pkgver = 1.06
+ pkgrel = 12
+ url = https://github.com/garrigue/lablgl
arch = x86_64
license = BSD
- makedepends = camlp4
depends = glu
depends = glut
depends = libxi
depends = libxmu
depends = libgl
- depends = ocaml>=4.02
+ depends = ocaml>=4.14.0
options = !strip
options = !makeflags
options = staticlibs
- source = https://forge.ocamlcore.org/frs/download.php/1254/lablgl-1.05.tar.gz
- sha256sums = d8ff03e35b970d2b23a942f9e6ed65da5a6c123986bd0ecf5424a6205af34b61
+ source = ocaml-lablgl-1.06.tar.gz::https://github.com/garrigue/lablgl/archive/v1.06.tar.gz
+ sha256sums = d11852cbdbd40a14a22b30a218d009033c810de461e5717582f5dbe480296a7a
pkgname = ocaml-lablgl
-
diff --git a/PKGBUILD b/PKGBUILD
index bafc8d93b731..6cfdc11edf37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,46 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
# Contributor: Florian Dejonckheere <florian@floriandejonckheere.be>
# Contributor: Bartłomiej Piotrowski <spam@bpiotrowski.pl>
# Contributor: Nikolay Amiantov <nikoamia@gmail.com>
pkgname=ocaml-lablgl
-pkgver=1.05
-pkgrel=4
+pkgver=1.06
+pkgrel=12
pkgdesc='OCaml interface to OpenGL'
-url="https://forge.ocamlcore.org/projects/lablgl/"
-arch=('i686' 'x86_64')
+url="https://github.com/garrigue/lablgl"
+arch=('x86_64')
license=('BSD')
-depends=('glu' 'glut' 'libxi' 'libxmu' 'libgl' 'ocaml>=4.02')
-makedepends=('camlp4')
+depends=('glu' 'glut' 'libxi' 'libxmu' 'libgl' 'ocaml>=4.14.0')
options=('!strip' '!makeflags' 'staticlibs')
-source=("https://forge.ocamlcore.org/frs/download.php/1254/lablgl-$pkgver.tar.gz")
-sha256sums=('d8ff03e35b970d2b23a942f9e6ed65da5a6c123986bd0ecf5424a6205af34b61')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('d11852cbdbd40a14a22b30a218d009033c810de461e5717582f5dbe480296a7a')
prepare() {
- cd "lablgl-$pkgver"
- sed 17d Makefile.config.linux.mdk > Makefile.config
+ cd "${srcdir}"/lablgl-${pkgver}
+
+ printf 'RANLIB = :\n' > Makefile.config
+ printf 'GLLIBS = -lGL -lGLU\n' >> Makefile.config
+ printf 'GLUTLIBS = -lglut\n' >> Makefile.config
}
build() {
- cd "lablgl-$pkgver"
+ cd "${srcdir}"/lablgl-${pkgver}
+
make lib
make libopt
}
package() {
- cd "lablgl-$pkgver"
+ cd "${srcdir}"/lablgl-${pkgver}
- make install BINDIR="$pkgdir/usr/bin/" \
- LIBDIR="$pkgdir/usr/lib/ocaml/" \
- DDLDIR="$pkgdir/usr/lib/ocaml/stublibs/" \
- INSTALLDIR="$pkgdir/usr/lib/ocaml/lablGL/"
+ # Install routines are broken and don't ensure this is created first.
+ mkdir -p "${pkgdir}"/usr/lib/ocaml/stublibs
- install -Dm644 src/lablgl.cmxa "$pkgdir"/usr/lib/ocaml/lablgl.cmxa
- install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make install BINDIR="${pkgdir}/usr/bin/" \
+ LIBDIR="${pkgdir}/usr/lib/ocaml/" \
+ DDLDIR="${pkgdir}/usr/lib/ocaml/stublibs/" \
+ INSTALLDIR="${pkgdir}/usr/lib/ocaml/lablGL/"
- # Hack for wrongly placed stublibs library
- mv "$pkgdir/usr/lib/ocaml/stublibs" /tmp/temp.so
- mkdir -p "$pkgdir/usr/lib/ocaml/stublibs"
- mv /tmp/temp.so "$pkgdir/usr/lib/ocaml/stublibs/dlllablgl.so"
+ install -Dm644 src/lablgl.cmxa "${pkgdir}"/usr/lib/ocaml/lablgl.cmxa
+ install -Dm644 COPYRIGHT "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}