summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Oteiza2015-06-08 22:45:20 -0400
committerMark Oteiza2015-06-08 22:45:20 -0400
commit24f881e64289b92d20bf959d11680311348ed5dc (patch)
tree5503d57eb35296bbf9b837cb68105da69e888bf6
downloadaur-24f881e64289b92d20bf959d11680311348ed5dc.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72e5d27c59e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ocaml-lablgl
+ pkgdesc = OCaml interface to OpenGL
+ pkgver = 1.05
+ pkgrel = 4
+ url = https://forge.ocamlcore.org/projects/lablgl/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = camlp4
+ depends = glu
+ depends = glut
+ depends = libxi
+ depends = libxmu
+ depends = libgl
+ depends = ocaml>=4.02
+ options = !strip
+ options = !makeflags
+ options = staticlibs
+ source = https://forge.ocamlcore.org/frs/download.php/1254/lablgl-1.05.tar.gz
+ sha256sums = d8ff03e35b970d2b23a942f9e6ed65da5a6c123986bd0ecf5424a6205af34b61
+
+pkgname = ocaml-lablgl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bafc8d93b731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Florian Dejonckheere <florian@floriandejonckheere.be>
+# Contributor: Bartłomiej Piotrowski <spam@bpiotrowski.pl>
+# Contributor: Nikolay Amiantov <nikoamia@gmail.com>
+
+pkgname=ocaml-lablgl
+pkgver=1.05
+pkgrel=4
+pkgdesc='OCaml interface to OpenGL'
+url="https://forge.ocamlcore.org/projects/lablgl/"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('glu' 'glut' 'libxi' 'libxmu' 'libgl' 'ocaml>=4.02')
+makedepends=('camlp4')
+options=('!strip' '!makeflags' 'staticlibs')
+source=("https://forge.ocamlcore.org/frs/download.php/1254/lablgl-$pkgver.tar.gz")
+sha256sums=('d8ff03e35b970d2b23a942f9e6ed65da5a6c123986bd0ecf5424a6205af34b61')
+
+prepare() {
+ cd "lablgl-$pkgver"
+ sed 17d Makefile.config.linux.mdk > Makefile.config
+}
+
+build() {
+ cd "lablgl-$pkgver"
+ make lib
+ make libopt
+}
+
+package() {
+ cd "lablgl-$pkgver"
+
+ make install BINDIR="$pkgdir/usr/bin/" \
+ LIBDIR="$pkgdir/usr/lib/ocaml/" \
+ DDLDIR="$pkgdir/usr/lib/ocaml/stublibs/" \
+ INSTALLDIR="$pkgdir/usr/lib/ocaml/lablGL/"
+
+ install -Dm644 src/lablgl.cmxa "$pkgdir"/usr/lib/ocaml/lablgl.cmxa
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Hack for wrongly placed stublibs library
+ mv "$pkgdir/usr/lib/ocaml/stublibs" /tmp/temp.so
+ mkdir -p "$pkgdir/usr/lib/ocaml/stublibs"
+ mv /tmp/temp.so "$pkgdir/usr/lib/ocaml/stublibs/dlllablgl.so"
+}