summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 21:00:17 +0200
committerJ5lx2015-10-10 21:00:17 +0200
commita4c3128944d5a2ebc03d29872e623ad5ea297334 (patch)
tree83f73668299a5af40570044581773443d7503c16
downloadaur-a4c3128944d5a2ebc03d29872e623ad5ea297334.tar.gz
0.1.5-1: Initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9053b2312c22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-ladspa
+ pkgdesc = OCaml bindings for LADSPA plugins
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-ladspa
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ makedepends = ladspa
+ depends = ocaml
+ options = !strip
+ source = https://github.com/savonet/ocaml-ladspa/releases/download/0.1.5/ocaml-ladspa-0.1.5.tar.gz
+ md5sums = ae66337eb15dbbf0f432016e79db7267
+
+pkgname = ocaml-ladspa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd7854a28d4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ladspa
+pkgver=0.1.5
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings for LADSPA plugins")
+url="https://github.com/savonet/ocaml-ladspa"
+depends=('ocaml')
+makedepends=('ocaml-findlib' 'ladspa')
+source=("https://github.com/savonet/ocaml-ladspa/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('ae66337eb15dbbf0f432016e79db7267')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}