summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302021-03-10 10:43:44 +0100
committerM0Rf302021-03-10 10:43:44 +0100
commitae3af8f37ca6e4857dbec518e496504d549456df (patch)
tree7446506fb29f5dcaaaebd3378ab878011f119bdd
parent94d474dcf89d58490adf4846b1a77becbd1a96b4 (diff)
downloadaur-ae3af8f37ca6e4857dbec518e496504d549456df.tar.gz
ocaml-ladspa: 0.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abf0ca95a637..56e0553c0fe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue Jun 6 10:01:55 UTC 2017
pkgbase = ocaml-ladspa
pkgdesc = OCaml bindings for LADSPA plugins
- pkgver = 0.1.5
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/savonet/ocaml-ladspa
arch = i686
arch = x86_64
license = LGPL2.1
- makedepends = ocaml-findlib
+ makedepends = dune
makedepends = ladspa
+ makedepends = ocaml-findlib
depends = ocaml
options = !strip
- source = https://github.com/savonet/ocaml-ladspa/releases/download/0.1.5/ocaml-ladspa-0.1.5.tar.gz
- md5sums = ae66337eb15dbbf0f432016e79db7267
+ source = https://github.com/savonet/ocaml-ladspa/archive/v0.2.0.tar.gz
+ sha256sums = a2cdb620d118100d399ff7e14534909acc207224c519605f317f1542db9b61c5
pkgname = ocaml-ladspa
diff --git a/PKGBUILD b/PKGBUILD
index 26e88eb557c8..a4dae353c4c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ladspa
-pkgver=0.1.5
+pkgver=0.2.0
pkgrel=1
pkgdesc="OCaml bindings for LADSPA plugins"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-ladspa"
license=('LGPL2.1')
depends=('ocaml')
-makedepends=('ocaml-findlib' 'ladspa')
+makedepends=('dune' 'ladspa' 'ocaml-findlib')
options=('!strip')
-source=("https://github.com/savonet/ocaml-ladspa/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('ae66337eb15dbbf0f432016e79db7267')
+source=("${url}/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
+
+sha256sums=('a2cdb620d118100d399ff7e14534909acc207224c519605f317f1542db9b61c5')