summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2015-06-10 15:17:58 +0800
committerwenLiangcan2015-06-10 15:17:58 +0800
commit2bc8a0828f6a36b584dd2725e07c22f40e6fefd0 (patch)
treeb8faed1ca4e191257ed210ea333a1317ec4aa144
downloadaur-2bc8a0828f6a36b584dd2725e07c22f40e6fefd0.tar.gz
ocaml-lambda-term 1.8-1.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25f0894125e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ocaml-lambda-term
+ pkgdesc = A cross-platform library for manipulating the terminal
+ pkgver = 1.8
+ pkgrel = 1
+ url = https://github.com/diml/lambda-term
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-lwt
+ depends = ocaml-react
+ depends = ocaml-zed
+ options = !strip
+ source = https://github.com/diml/lambda-term/archive/1.8.tar.gz
+ md5sums = 77c09a0a58beae9f092db6e91ddae808
+
+pkgname = ocaml-lambda-term
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9dd61149763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Contributor: Taylor Venable <taylor@metasyntax.net>
+
+srcname='lambda-term'
+pkgname="ocaml-${srcname}"
+pkgver='1.8'
+pkgrel=1
+pkgdesc='A cross-platform library for manipulating the terminal'
+arch=('i686' 'x86_64')
+url='https://github.com/diml/lambda-term'
+license=('BSD')
+depends=('ocaml' 'ocaml-lwt' 'ocaml-react' 'ocaml-zed')
+makedepends=('ocaml-findlib')
+source=("https://github.com/diml/lambda-term/archive/${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('77c09a0a58beae9f092db6e91ddae808')
+
+build() {
+ cd "$srcdir/${srcname}-${pkgver}"
+ ./configure --prefix /usr --destdir "$pkgdir"
+
+ env DESTDIR="$pkgdir" \
+ OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ make
+}
+
+
+package() {
+ install -dm755 "$pkgdir/$(ocamlfind printconf destdir)"
+ install -dm755 "$pkgdir/$(ocamlfind printconf destdir)/stublibs"
+ cd "$srcdir/${srcname}-${pkgver}"
+ env DESTDIR="$pkgdir" \
+ OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ make install
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}