summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-26 01:47:44 +0200
committerDaniel Peukert2020-04-26 01:47:44 +0200
commit640ad7d0c805c28f58ebfa1c0c705ff39ff2d163 (patch)
tree56b0c0025c07132c3cd221321f10ebc9c64a6000
parenta84efbb518a9de0f1ac3e785061c7ccb4f5a2975 (diff)
downloadaur-640ad7d0c805c28f58ebfa1c0c705ff39ff2d163.tar.gz
Updated ocaml-lambda-term to 3.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--ocaml-lambda-term.install4
3 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac9e311a6842..ad922b7aaee9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = ocaml-lambda-term
pkgdesc = Terminal manipulation library for OCaml
- pkgver = 2.0.3
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/ocaml-community/lambda-term
+ install = ocaml-lambda-term.install
arch = x86_64
arch = i686
arch = arm
@@ -10,15 +11,16 @@ pkgbase = ocaml-lambda-term
arch = armv7h
arch = aarch64
license = BSD
- makedepends = dune>=1.0.0
+ makedepends = dune>=1.1.0
depends = ocaml>=4.02.3
depends = ocaml-camomile>=1.0.1
depends = ocaml-lwt>=4.0.0
depends = ocaml-lwt_log
+ depends = ocaml-mew_vi>=0.3.0
depends = ocaml-react
- depends = ocaml-zed>=2.0.3
+ depends = ocaml-zed>=3.0.0
options = !strip
- source = ocaml-lambda-term-2.0.3-1.tar.gz::https://github.com/ocaml-community/lambda-term/archive/2.0.3.tar.gz
- sha256sums = 56e26288e05aa5f06b10b680ccd633f77926fa1eac04781a0c88fa9a65f12c82
+ source = ocaml-lambda-term-3.0.0-1.tar.gz::https://github.com/ocaml-community/lambda-term/archive/3.0.0.tar.gz
+ sha256sums = 65e16c9a52fa03a6b3a3772566414b0d35cadceac3f244301ef56dad4c6ccc18
pkgname = ocaml-lambda-term
diff --git a/PKGBUILD b/PKGBUILD
index db563c576310..bcc155f5b176 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,18 @@
# Contributor: Taylor Venable <taylor@metasyntax.net>
_projectname='lambda-term'
pkgname="ocaml-$_projectname"
-pkgver='2.0.3'
+pkgver='3.0.0'
pkgrel='1'
pkgdesc='Terminal manipulation library for OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
license=('BSD')
-depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-lwt>=4.0.0' 'ocaml-lwt_log' 'ocaml-react' 'ocaml-zed>=2.0.3')
-makedepends=('dune>=1.0.0')
+depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-lwt>=4.0.0' 'ocaml-lwt_log' 'ocaml-mew_vi>=0.3.0' 'ocaml-react' 'ocaml-zed>=3.0.0')
+makedepends=('dune>=1.1.0')
options=('!strip')
+install="$pkgname.install"
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('56e26288e05aa5f06b10b680ccd633f77926fa1eac04781a0c88fa9a65f12c82')
+sha256sums=('65e16c9a52fa03a6b3a3772566414b0d35cadceac3f244301ef56dad4c6ccc18')
_sourcedirectory="$_projectname-$pkgver"
@@ -25,7 +26,7 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' -p "$_projectname" --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
diff --git a/ocaml-lambda-term.install b/ocaml-lambda-term.install
new file mode 100644
index 000000000000..e0805701406d
--- /dev/null
+++ b/ocaml-lambda-term.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo '==> An example key bindings file has been provided in /usr/share/lambda-term-inputrc,'
+ echo '==> copy it to ~/.config/.lambda-term-inputrc if you wish to customize it'
+}