summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-10 03:21:22 +0200
committerDaniel Peukert2020-04-10 03:21:22 +0200
commita84efbb518a9de0f1ac3e785061c7ccb4f5a2975 (patch)
tree20affa0a4c57e233eef1efb5c8faf2d50d797796
parent05001809a11cc53a1cc0beea2b72004dd0fb069c (diff)
downloadaur-a84efbb518a9de0f1ac3e785061c7ccb4f5a2975.tar.gz
Added ocaml-utop & dependencies
-rw-r--r--.SRCINFO27
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD47
4 files changed, 64 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f06163e766a..ac9e311a6842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = ocaml-lambda-term
- pkgdesc = A cross-platform library for manipulating the terminal
- pkgver = 2.0.2
+ pkgdesc = Terminal manipulation library for OCaml
+ pkgver = 2.0.3
pkgrel = 1
- url = https://github.com/diml/lambda-term
- arch = i686
+ url = https://github.com/ocaml-community/lambda-term
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = BSD
- makedepends = dune
- depends = ocaml
- depends = ocaml-lwt
+ makedepends = dune>=1.0.0
+ depends = ocaml>=4.02.3
+ depends = ocaml-camomile>=1.0.1
+ depends = ocaml-lwt>=4.0.0
depends = ocaml-lwt_log
depends = ocaml-react
- depends = ocaml-zed
- depends = ocaml-camomile
+ depends = ocaml-zed>=2.0.3
options = !strip
- source = https://github.com/diml/lambda-term/releases/download/2.0.2/lambda-term-2.0.2.tbz
- sha512sums = 61b4f3d80a8e17562cd7efe3a15258134a41fad67db200e9bde8896e39bff63c3274f3fff54f0233441555b5119fddcbea80fbab9b82caaa0b6b4deb56843f09
+ source = ocaml-lambda-term-2.0.3-1.tar.gz::https://github.com/ocaml-community/lambda-term/archive/2.0.3.tar.gz
+ sha256sums = 56e26288e05aa5f06b10b680ccd633f77926fa1eac04781a0c88fa9a65f12c82
pkgname = ocaml-lambda-term
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index e7ceccedb40e..db563c576310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,38 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
# Contributor: wenLiangcan <boxeed at gmail dot com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
-
-pkgname=ocaml-lambda-term
-pkgver=2.0.2
-pkgrel=1
-pkgdesc='A cross-platform library for manipulating the terminal'
-arch=('i686' 'x86_64')
-url="https://github.com/diml/lambda-term"
+_projectname='lambda-term'
+pkgname="ocaml-$_projectname"
+pkgver='2.0.3'
+pkgrel='1'
+pkgdesc='Terminal manipulation library for OCaml'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/ocaml-community/$_projectname"
license=('BSD')
-depends=('ocaml' 'ocaml-lwt' 'ocaml-lwt_log' 'ocaml-react' 'ocaml-zed' 'ocaml-camomile')
-makedepends=('dune')
+depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-lwt>=4.0.0' 'ocaml-lwt_log' 'ocaml-react' 'ocaml-zed>=2.0.3')
+makedepends=('dune>=1.0.0')
options=('!strip')
-source=("https://github.com/diml/lambda-term/releases/download/${pkgver}/lambda-term-${pkgver}.tbz")
-sha512sums=('61b4f3d80a8e17562cd7efe3a15258134a41fad67db200e9bde8896e39bff63c3274f3fff54f0233441555b5119fddcbea80fbab9b82caaa0b6b4deb56843f09')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('56e26288e05aa5f06b10b680ccd633f77926fa1eac04781a0c88fa9a65f12c82')
-build() {
- cd "${srcdir}/lambda-term-${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- dune build --profile release
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
-
package() {
- cd "${srcdir}/lambda-term-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
+
+ mv "$pkgdir/usr/man/" "$pkgdir/usr/share/man/"
- dune install --destdir "${pkgdir}"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/man" "${pkgdir}/usr/share/"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}