summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-27 09:12:19 +0200
committerDaniel Peukert2020-04-27 09:12:19 +0200
commitbcb8f446e14fe54a35d10eab9793ea5285bf665d (patch)
tree531ce3a7f55fb1202d66567bfa756aaf0415e367
parent640ad7d0c805c28f58ebfa1c0c705ff39ff2d163 (diff)
downloadaur-bcb8f446e14fe54a35d10eab9793ea5285bf665d.tar.gz
Fixed ocaml-lambda-term to work with the new version of ocaml-mew_vi
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad922b7aaee9..ee6fc348e84d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-lambda-term
pkgdesc = Terminal manipulation library for OCaml
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ocaml-community/lambda-term
install = ocaml-lambda-term.install
arch = x86_64
@@ -16,11 +16,15 @@ pkgbase = ocaml-lambda-term
depends = ocaml-camomile>=1.0.1
depends = ocaml-lwt>=4.0.0
depends = ocaml-lwt_log
- depends = ocaml-mew_vi>=0.3.0
+ depends = ocaml-mew_vi>=0.4.0
depends = ocaml-react
depends = ocaml-zed>=3.0.0
options = !strip
- source = ocaml-lambda-term-3.0.0-1.tar.gz::https://github.com/ocaml-community/lambda-term/archive/3.0.0.tar.gz
+ source = ocaml-lambda-term-3.0.0-2.tar.gz::https://github.com/ocaml-community/lambda-term/archive/3.0.0.tar.gz
+ source = ocaml-lambda-term-3.0.0-2-fix-vi-visual-mode.diff::https://github.com/ocaml-community/lambda-term/commit/e7b8cc0f09b7caf1d03bd512e2f081c78e29e688.diff
+ source = ocaml-lambda-term-3.0.0-2-fix-tests.diff::https://github.com/ocaml-community/lambda-term/commit/105a1460b41b6c3f0c3d0c9dc260e0a50b13f7c9.diff
sha256sums = 65e16c9a52fa03a6b3a3772566414b0d35cadceac3f244301ef56dad4c6ccc18
+ sha256sums = d75ce1747c065c1207174c1f43381c0310810917787901d557b8336f779cba34
+ sha256sums = 04b2ca408fe9b0b3ebd52edea79588ed36838fb5220f9256a6805c2def102c3d
pkgname = ocaml-lambda-term
diff --git a/PKGBUILD b/PKGBUILD
index bcc155f5b176..358f51cd652d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,32 @@
_projectname='lambda-term'
pkgname="ocaml-$_projectname"
pkgver='3.0.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Terminal manipulation library for OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
license=('BSD')
-depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-lwt>=4.0.0' 'ocaml-lwt_log' 'ocaml-mew_vi>=0.3.0' 'ocaml-react' 'ocaml-zed>=3.0.0')
+depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-lwt>=4.0.0' 'ocaml-lwt_log' 'ocaml-mew_vi>=0.4.0' 'ocaml-react' 'ocaml-zed>=3.0.0')
makedepends=('dune>=1.1.0')
options=('!strip')
install="$pkgname.install"
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('65e16c9a52fa03a6b3a3772566414b0d35cadceac3f244301ef56dad4c6ccc18')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-fix-vi-visual-mode.diff::$url/commit/e7b8cc0f09b7caf1d03bd512e2f081c78e29e688.diff"
+ "$pkgname-$pkgver-$pkgrel-fix-tests.diff::$url/commit/105a1460b41b6c3f0c3d0c9dc260e0a50b13f7c9.diff"
+)
+sha256sums=('65e16c9a52fa03a6b3a3772566414b0d35cadceac3f244301ef56dad4c6ccc18'
+ 'd75ce1747c065c1207174c1f43381c0310810917787901d557b8336f779cba34'
+ '04b2ca408fe9b0b3ebd52edea79588ed36838fb5220f9256a6805c2def102c3d')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ patch --forward -p1 < "$srcdir/$pkgname-$pkgver-$pkgrel-fix-vi-visual-mode.diff"
+ patch --forward -p1 < "$srcdir/$pkgname-$pkgver-$pkgrel-fix-tests.diff"
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
dune build -p "$_projectname" --verbose