summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-27 23:58:05 +0100
committerGianluca Boiano2021-02-27 23:58:05 +0100
commitd09013a5bd44bc15efa660ce3ed42766bebea281 (patch)
tree563603f18e7440e56b29cf0902414c8979479189
parentebeee2eefb43d313f2f7ff5018b610a794d224b3 (diff)
downloadaur-d09013a5bd44bc15efa660ce3ed42766bebea281.tar.gz
ocaml-lame: 0.3.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47b4614c5202..884a81720147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Tue Jun 6 10:03:40 UTC 2017
pkgbase = ocaml-lame
pkgdesc = OCaml bindings to the LAME mp3 encoder
- pkgver = 0.3.3
- pkgrel = 2
+ pkgver = 0.3.4
+ pkgrel = 1
url = https://github.com/savonet/ocaml-lame
arch = i686
arch = x86_64
license = GPL2
- makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml
depends = lame
options = !strip
- source = https://github.com/savonet/ocaml-lame/releases/download/0.3.3/ocaml-lame-0.3.3.tar.gz
- md5sums = a1585835f94f8d459157263ed2aaede3
+ source = https://github.com/savonet/ocaml-lame/archive/v0.3.4.tar.gz
+ sha256sums = f90b9e090b3fc27437b64dd05c15b92778f07cf4f3d82e0f8186299cb8e1102d
pkgname = ocaml-lame
diff --git a/PKGBUILD b/PKGBUILD
index fb8db64cb1b1..5096c34d79d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-lame
-pkgver=0.3.3
-pkgrel=2
+pkgver=0.3.4
+pkgrel=1
pkgdesc="OCaml bindings to the LAME mp3 encoder"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-lame"
license=('GPL2')
depends=('ocaml' 'lame')
-makedepends=('ocaml-findlib')
+makedepends=('dune')
options=('!strip')
-source=("https://github.com/savonet/ocaml-lame/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('a1585835f94f8d459157263ed2aaede3')
+source=("${url}/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
- make
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
}
+
+sha256sums=('f90b9e090b3fc27437b64dd05c15b92778f07cf4f3d82e0f8186299cb8e1102d')