summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 21:50:37 +0100
committerGianluca Boiano2021-02-28 21:50:37 +0100
commitd0af398cd7113f7b92f726e0153e21ea5e7f894b (patch)
treed6ee81857f99b52c84e9d946c1f0c8d206a988e6
parentd09013a5bd44bc15efa660ce3ed42766bebea281 (diff)
downloadaur-d0af398cd7113f7b92f726e0153e21ea5e7f894b.tar.gz
ocaml-lame: fix dune compilation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 884a81720147..eba96320ea3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = ocaml-lame
pkgdesc = OCaml bindings to the LAME mp3 encoder
pkgver = 0.3.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/savonet/ocaml-lame
arch = i686
arch = x86_64
license = GPL2
+ makedepends = ocaml-findlib
makedepends = dune
depends = ocaml
depends = lame
diff --git a/PKGBUILD b/PKGBUILD
index 5096c34d79d3..b7f276ec0095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=ocaml-lame
pkgver=0.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="OCaml bindings to the LAME mp3 encoder"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-lame"
license=('GPL2')
depends=('ocaml' 'lame')
-makedepends=('dune')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
source=("${url}/archive/v${pkgver}.tar.gz")
@@ -22,8 +22,10 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
sha256sums=('f90b9e090b3fc27437b64dd05c15b92778f07cf4f3d82e0f8186299cb8e1102d')