summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 23:07:47 +0100
committerGianluca Boiano2021-02-28 23:07:47 +0100
commitafd5537de9a20fdd67526641bfe80863d989a08d (patch)
treeb6dbd1caa1211f2557ce2ede500b40906924e8b2
parent9c30b185f43a45b008cd91925fa3188ac1d4a2df (diff)
downloadaur-afd5537de9a20fdd67526641bfe80863d989a08d.tar.gz
ocaml-lastfm: 0.3.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac31aeebd352..de95ade86005 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = ocaml-lastfm
pkgdesc = OCaml API to lastfm radio and audioscrobbler
- pkgver = 0.3.2
+ pkgver = 0.3.3
pkgrel = 1
url = https://github.com/savonet/ocaml-lastfm
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml
depends = ocaml-pcre
depends = ocaml-xmlplaylist
depends = ocamlnet
options = !strip
- source = https://github.com/savonet/ocaml-lastfm/releases/download/0.3.2/ocaml-lastfm-0.3.2.tar.gz
- md5sums = 4750e5b6af1eada76841c89f46427be6
+ source = https://github.com/savonet/ocaml-lastfm/archive/v0.3.3.tar.gz
+ sha256sums = e0c05c3221f0faa09d7c2447573181067bf9f192cadbfadb7b97067c72add73a
pkgname = ocaml-lastfm
diff --git a/PKGBUILD b/PKGBUILD
index 3c75933f1fb4..47d89ed0138c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-lastfm
-pkgver=0.3.2
+pkgver=0.3.3
pkgrel=1
pkgdesc="OCaml API to lastfm radio and audioscrobbler"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-lastfm"
license=('LGPL2.1')
depends=('ocaml' 'ocaml-pcre' 'ocaml-xmlplaylist' 'ocamlnet')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
-source=("https://github.com/savonet/ocaml-lastfm/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('4750e5b6af1eada76841c89f46427be6')
+source=("${url}/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
- make
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
- make install
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
+
+sha256sums=('e0c05c3221f0faa09d7c2447573181067bf9f192cadbfadb7b97067c72add73a')