summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2016-02-07 02:51:33 +0100
committerJ5lx2016-02-07 02:51:33 +0100
commitb77d5dde824fa743683170079a7f9afe89f57d89 (patch)
treeaa3ad6cd7c5b3d0d30d630ccfb2aa2c87c519670
downloadaur-b77d5dde824fa743683170079a7f9afe89f57d89.tar.gz
2014.08.08-1: Initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f25a100b58dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 01:51:03 UTC 2016
+pkgbase = ocaml-libocaml_exception
+ pkgdesc = OCaml library for statically-typed exceptions
+ pkgver = 2014.08.08
+ pkgrel = 1
+ url = http://git.grenouille.com/?p=libocaml_exception.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-lwt
+ options = !strip
+ source = git://git.autogeree.net/~julm/libocaml_exception.git#tag=v2014-08-08
+ source = git://git.autogeree.net/~julm/libocaml_make.git#tag=v2014-08-08
+ source = git://git.autogeree.net/~julm/tool/pkg.git#tag=v2014-08-07
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ocaml-libocaml_exception
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7bd08af5c47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-libocaml_exception
+pkgver=2014.08.08
+pkgrel=1
+license=('GPL3')
+arch=('i686' 'x86_64')
+pkgdesc="OCaml library for statically-typed exceptions"
+url="http://git.grenouille.com/?p=libocaml_exception.git"
+depends=('ocaml' 'ocaml-lwt')
+makedepends=('git' 'ocaml-findlib')
+source=("git://git.autogeree.net/~julm/libocaml_exception.git#tag=v${pkgver//./-}"
+ "git://git.autogeree.net/~julm/libocaml_make.git#tag=v2014-08-08"
+ "git://git.autogeree.net/~julm/tool/pkg.git#tag=v2014-08-07")
+options=('!strip')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}"
+
+ git submodule init
+ git config submodule.lib/libocaml/make.url "${srcdir}/libocaml_make"
+ git config submodule.lib/tool/pkg.url "${srcdir}/pkg"
+ git submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlc -where)"
+ install -dm755 "${OCAMLFIND_DESTDIR}"
+ make install DESTDIR="${OCAMLFIND_DESTDIR}"
+}