summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2016-02-07 04:48:14 +0100
committerJ5lx2016-02-07 04:48:14 +0100
commitdd463a91ae5fd70efa98b348c0829ff89607eb30 (patch)
tree7b2ae019fc6af59d18c9174cf1d8bae94920a73b
downloadaur-dd463a91ae5fd70efa98b348c0829ff89607eb30.tar.gz
2014.08.08-1: Initial upload
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD41
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3902e49de907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 03:47:47 UTC 2016
+pkgbase = ocaml-libocaml_http
+ pkgdesc = OCaml library for HTTP
+ pkgver = 2014.08.08
+ pkgrel = 1
+ url = http://git.grenouille.com/?p=libocaml_http.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-libocaml_lexing
+ depends = ocaml-libocaml_option
+ depends = ocaml-libocaml_plus
+ depends = ocaml-libocaml_uri
+ options = !strip
+ source = git://git.autogeree.net/~julm/libocaml_http.git#tag=v2014-08-08
+ source = git://git.autogeree.net/~julm/libocaml_make.git#tag=v2014-08-08
+ source = git://git.autogeree.net/~julm/tool/pkg.git#tag=v2014-08-07
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ocaml-libocaml_http
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..029c785636fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-libocaml_http
+pkgver=2014.08.08
+pkgrel=1
+license=('GPL3')
+arch=('i686' 'x86_64')
+pkgdesc="OCaml library for HTTP"
+url="http://git.grenouille.com/?p=libocaml_http.git"
+depends=('ocaml' 'ocaml-libocaml_lexing' 'ocaml-libocaml_option' 'ocaml-libocaml_plus' 'ocaml-libocaml_uri')
+makedepends=('git' 'ocaml-findlib')
+source=("git://git.autogeree.net/~julm/libocaml_http.git#tag=v${pkgver//./-}"
+ "git://git.autogeree.net/~julm/libocaml_make.git#tag=v2014-08-08"
+ "git://git.autogeree.net/~julm/tool/pkg.git#tag=v2014-08-07")
+options=('!strip')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}"
+
+ git submodule init
+ git config submodule.lib/libocaml/make.url "${srcdir}/libocaml_make"
+ git config submodule.lib/tool/pkg.url "${srcdir}/pkg"
+ git submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}"
+
+ make OCAML_FLAGS=
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlc -where)"
+ install -dm755 "${OCAMLFIND_DESTDIR}"
+ make install DESTDIR="${OCAMLFIND_DESTDIR}"
+}