summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 21:39:00 +0200
committerJ5lx2015-10-10 21:39:00 +0200
commit2af3fb63d8aa4b8251e8107f9d27557203f10024 (patch)
tree75717839f0e21444ce7cba47a373185b4431949d
downloadaur-2af3fb63d8aa4b8251e8107f9d27557203f10024.tar.gz
0.1.1-1: Initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fc4e3c32193
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-lo
+ pkgdesc = OCaml bindings for LO library
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-lo
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = liblo
+ options = !strip
+ source = https://github.com/savonet/ocaml-lo/releases/download/0.1.1/ocaml-lo-0.1.1.tar.gz
+ md5sums = 8534c358aa497e96e6af033a20ba0fc4
+
+pkgname = ocaml-lo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..983f2eeea65c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-lo
+pkgver=0.1.1
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings for LO library")
+url="https://github.com/savonet/ocaml-lo"
+depends=('ocaml' 'liblo')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-lo/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('8534c358aa497e96e6af033a20ba0fc4')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}