summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-08-11 02:37:27 +0200
committerDaniel Peukert2023-08-11 02:37:27 +0200
commit7d0a8e1615ff9c045d1a06629e9e65b44e9a7be5 (patch)
tree996cd51d52082a19282a8925a42e08cf4db0aea8
parent1a1b87d069bb7083a1bf48d3a6eeeae4c30ebda3 (diff)
downloadaur-7d0a8e1615ff9c045d1a06629e9e65b44e9a7be5.tar.gz
Fix ocaml-fmt dep type for ocaml-logs
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a56c39e4af8..23419c9bcd62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = ocaml-logs
pkgdesc = Logging infrastructure for OCaml
pkgver = 0.7.0
- pkgrel = 5
+ pkgrel = 6
url = https://erratique.ch/software/logs
arch = x86_64
arch = aarch64
license = ISC
makedepends = ocamlbuild
makedepends = ocaml-findlib
- makedepends = ocaml-fmt
makedepends = ocaml-topkg>=1.0.3
makedepends = opam
depends = ocaml>=4.03.0
depends = ocaml-cmdliner
+ depends = ocaml-fmt
+ depends = ocaml-js_of_ocaml>=3.3.0
depends = ocaml-lwt
options = !strip
source = ocaml-logs-0.7.0.tar.gz::https://github.com/dbuenzli/logs/archive/v0.7.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 696e5aa91b8a..503b60d3a79d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,13 @@
_projectname='logs'
pkgname="ocaml-$_projectname"
pkgver='0.7.0'
-pkgrel='5'
+pkgrel='6'
pkgdesc='Logging infrastructure for OCaml'
-# If you're running on aarch64, you have to add it to the arch array of the cppo, ocaml-biniou, ocaml-cmdliner, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://erratique.ch/software/$_projectname"
license=('ISC')
-# TODO: package ocaml-js_of_ocaml >=3.3.0
-depends=('ocaml>=4.03.0' 'ocaml-cmdliner' 'ocaml-lwt')
-makedepends=('ocamlbuild' 'ocaml-findlib' 'ocaml-fmt' 'ocaml-topkg>=1.0.3' 'opam')
+depends=('ocaml>=4.03.0' 'ocaml-cmdliner' 'ocaml-fmt' 'ocaml-js_of_ocaml>=3.3.0' 'ocaml-lwt')
+makedepends=('ocamlbuild' 'ocaml-findlib' 'ocaml-topkg>=1.0.3' 'opam')
options=('!strip')
source=("$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_projectname/archive/v$pkgver.tar.gz")
sha512sums=('071c4e0970f2ef86a78561407d6e333bb206ac11e0b14cdecfcf33e75701570986de11d7b1bc027cd3ec20d42da44b0242c4f8b343e4fbf75d58d8f01e4b3b81')
@@ -28,7 +26,7 @@ prepare() {
build() {
cd "$srcdir/$_sourcedirectory/"
- ocaml 'pkg/pkg.ml' build --with-base-threads true --with-cmdliner true --with-lwt true --with-fmt true --with-js_of_ocaml false
+ ocaml 'pkg/pkg.ml' build --with-base-threads true --with-cmdliner true --with-lwt true --with-fmt true --with-js_of_ocaml true
}
package() {