summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:08:17 +0100
committerDaniel Peukert2024-01-28 00:08:17 +0100
commit921720c0c8cf91e0666b8db236c82a9c863455fb (patch)
treebae8987df1c2317c78f26062c99ccb3a7b8de5df
parent921805cf425477037348292fda494029d6771b37 (diff)
downloadaur-ocaml-lwt.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD2
2 files changed, 15 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 93537a62e6ec..0929593c14e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,5 +46,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}