summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Kubica2015-06-08 21:08:59 +0200
committerMarek Kubica2015-06-08 21:10:14 +0200
commitb5c8919b0694e4617793d502359b6a506ded234a (patch)
tree9d81bb1b3df96f613d02053cf62a26968c324756
downloadaur-b5c8919b0694e4617793d502359b6a506ded234a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--ocaml-mascot.install9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36ab1c1428a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-mascot
+ pkgdesc = Style checker for OCaml sources
+ pkgver = 1.0
+ pkgrel = 3
+ url = http://mascot.x9c.fr
+ install = ocaml-mascot.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ocaml-findlib
+ depends = ocaml>=3.12.1
+ options = !strip !makeflags
+ source = http://mascot.x9c.fr/distrib/mascot-1.0.tar.gz
+ md5sums = 94a0abe41b9acbc4efa661dc9d7be122
+
+pkgname = ocaml-mascot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1487cd8e78a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Serge Zirukin <ftrvxmtrx@gmail.com>
+# Contributor: Sergei Lebedev <superbobry@gmail.com>
+
+pkgname=ocaml-mascot
+pkgver=1.0
+pkgrel=3
+pkgdesc="Style checker for OCaml sources"
+arch=("i686" "x86_64")
+url="http://mascot.x9c.fr"
+license=('GPL')
+depends=('ocaml>=3.12.1')
+makedepends=('ocaml-findlib')
+options=("!strip !makeflags")
+source=("http://mascot.x9c.fr/distrib/mascot-$pkgver.tar.gz")
+md5sums=('94a0abe41b9acbc4efa661dc9d7be122')
+install=ocaml-mascot.install
+
+
+build() {
+ cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
+ sh configure -ocaml-prefix /usr
+ make all
+}
+
+package() {
+ cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
+ export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
+ install -dm 755 "$OCAMLFIND_DESTDIR"
+ make install
+}
diff --git a/ocaml-mascot.install b/ocaml-mascot.install
new file mode 100644
index 000000000000..46edb71c33b9
--- /dev/null
+++ b/ocaml-mascot.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Creating symlink for /usr/lib/ocaml/mascot"
+ sudo ln -s /usr/lib/ocaml/mascot/mascot.native /usr/bin/mascot
+}
+
+post_remove() {
+ echo "Removing symlink for /usr/lib/ocaml/mascot"
+ sudo unlink /usr/bin/mascot
+}