summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-19 11:46:37 +0200
committerGoliathLabs2020-05-19 11:46:37 +0200
commit3476c0576c557329c4bc9db97e286a72290b5db2 (patch)
tree71fd8ac97b5f1456fac0af65f77bc941ab7a5faf
parentbcb038289be995bcf17fc43f05efa12e63c1db96 (diff)
downloadaur-3476c0576c557329c4bc9db97e286a72290b5db2.tar.gz
Updated: 20200211
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rwxr-xr-xcheck4u21
3 files changed, 17 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 568b02875044..ab840ebba3ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Oct 19 20:23:48 UTC 2019
pkgbase = ocaml-menhir
pkgdesc = Menhir is a LR(1) parser generator for the OCaml.
- pkgver = 20190924
- pkgrel = 2
+ pkgver = 20200211
+ pkgrel = 1
url = http://cristal.inria.fr/~fpottier/menhir/
arch = i686
arch = x86_64
@@ -11,11 +9,12 @@ pkgbase = ocaml-menhir
license = QPL
makedepends = ocamlbuild
makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml>=4.02
options = !strip
options = !makeflags
- source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20190924/menhir-20190924.tar.gz
- md5sums = 69b2cbcfb12ca0ca09ad0096c8716265
+ source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20200211/menhir-20200211.tar.gz
+ sha256sums = 00f677401a92d91568a4faffb4977ab71a32a265de59e35419ad5b705d4a532d
pkgname = ocaml-menhir
diff --git a/PKGBUILD b/PKGBUILD
index 341578f39b66..96f16324a274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Mort Yao <soi@mort.ninja>
+# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
# Contributor: Sergei Lebedev <superbobry@gmail.com>
# Contributor: Guillem Rieu <guillemr@gmx.net>
@@ -6,26 +7,28 @@
# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
pkgname=ocaml-menhir
-pkgver=20190924
-pkgrel=2
+pkgver=20200211
+pkgrel=1
pkgdesc="Menhir is a LR(1) parser generator for the OCaml."
arch=("i686" "x86_64")
url="http://cristal.inria.fr/~fpottier/menhir/"
license=('GPL' 'QPL')
depends=('ocaml>=4.02')
-makedepends=('ocamlbuild' 'ocaml-findlib')
+makedepends=('ocamlbuild' 'ocaml-findlib' 'dune')
options=(!strip !makeflags)
-source=("https://gitlab.inria.fr/fpottier/menhir/-/archive/$pkgver/menhir-$pkgver.tar.gz")
-md5sums=('69b2cbcfb12ca0ca09ad0096c8716265')
+source=("https://gitlab.inria.fr/fpottier/menhir/-/archive/20200211/menhir-${pkgver}.tar.gz")
+
+sha256sums=('00f677401a92d91568a4faffb4977ab71a32a265de59e35419ad5b705d4a532d')
build() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
- make PREFIX="/usr" all
+
+ dune build
}
package() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
- export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- install -dm 755 "$OCAMLFIND_DESTDIR"
- make PREFIX="$pkgdir/usr" install
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+
}
diff --git a/check4u b/check4u
deleted file mode 100755
index 028b5714023d..000000000000
--- a/check4u
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/usr/bin/env bash
-# ./check4u -- check for updates of a software package
-
-ocaml-menhir_latest() {
- local WEBPAGE='http://opam.ocaml.org/packages/menhir/'
- local DOWNLOAD_LINK=`curl --silent $WEBPAGE |
- grep -oP --color=NEVER '\d+/archive\.tar\.gz<'`
- LATEST=${DOWNLOAD_LINK%/archive.tar.gz<}
-}
-ocaml-menhir_current() {
- source PKGBUILD &&
- CURRENT="$pkgver"
-}
-
-ocaml-menhir_latest && ocaml-menhir_current
-
-if [[ "$LATEST" != "$CURRENT" ]]; then
- echo -e "Latest release : $LATEST"
- echo -e "Currently on AUR : $CURRENT"
- exit 1
-fi