summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2019-07-10 23:09:04 -0700
committerXuanrui Qi2019-07-10 23:09:04 -0700
commit284d2790299b5389a4d585429751784afb251762 (patch)
tree5d648458aebc697cc6d1db33626d6f0c35bd8088
downloadaur-284d2790299b5389a4d585429751784afb251762.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..339c8d7c167c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ocaml-menhir-compcert
+ pkgdesc = Latest version of Menhir that can build the latest CompCert release.
+ pkgver = 20181113
+ pkgrel = 1
+ url = http://cristal.inria.fr/~fpottier/menhir/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = QPL
+ makedepends = ocamlbuild
+ makedepends = ocaml-findlib
+ depends = ocaml>=4.02
+ provides = ocaml-menhir=20181113
+ conflicts = ocaml-menhir
+ options = !strip
+ options = !makeflags
+ source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20181113/menhir-20181113.tar.gz
+ md5sums = 1c57e4b6a99603bd4169506e3d937950
+
+pkgname = ocaml-menhir-compcert
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40ecb2b3cc60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+# Contributor: Mort Yao <soi@mort.ninja>
+# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
+# Contributor: Sergei Lebedev <superbobry@gmail.com>
+# Contributor: Guillem Rieu <guillemr@gmx.net>
+# Contributor: Sergey Plaksin <serp256@gmail.com>
+# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+
+pkgname=ocaml-menhir-compcert
+pkgver=20181113
+pkgrel=1
+pkgdesc="Latest version of Menhir that can build the latest CompCert release."
+arch=("i686" "x86_64")
+url="http://cristal.inria.fr/~fpottier/menhir/"
+license=('GPL' 'QPL')
+depends=('ocaml>=4.02')
+makedepends=('ocamlbuild' 'ocaml-findlib')
+provides=(ocaml-menhir=$pkgver)
+conflicts=(ocaml-menhir)
+options=(!strip !makeflags)
+source=("https://gitlab.inria.fr/fpottier/menhir/-/archive/$pkgver/menhir-$pkgver.tar.gz")
+md5sums=('1c57e4b6a99603bd4169506e3d937950')
+
+build() {
+ cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
+ make PREFIX="/usr" all
+}
+
+package() {
+ cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
+ export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
+ install -dm 755 "$OCAMLFIND_DESTDIR"
+ make PREFIX="$pkgdir/usr" install
+}