summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2020-06-01 03:09:47 +0900
committerXuanrui Qi2020-06-01 03:09:47 +0900
commit2fe30f48a5cc0d9c96d0d69ece1215c792c3ed35 (patch)
treecc6e1470d68bbd546d325d845d97399d86babf39
parent1431243c2eeac8f4661b0c1a889168d573555a04 (diff)
downloadaur-2fe30f48a5cc0d9c96d0d69ece1215c792c3ed35.tar.gz
Updated to 20200211
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bcd57aad5cd..027ac0413076 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-menhir-compcert
pkgdesc = Latest version of Menhir that can build the latest CompCert release.
- pkgver = 20190924
+ pkgver = 20200211
pkgrel = 1
url = http://cristal.inria.fr/~fpottier/menhir/
arch = i686
@@ -9,13 +9,14 @@ pkgbase = ocaml-menhir-compcert
license = QPL
makedepends = ocamlbuild
makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml>=4.02
- provides = ocaml-menhir=20190924
+ provides = ocaml-menhir=20200211
conflicts = ocaml-menhir
options = !strip
options = !makeflags
- source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20190924/menhir-20190924.tar.gz
- md5sums = 69b2cbcfb12ca0ca09ad0096c8716265
+ source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20200211/menhir-20200211.tar.gz
+ sha256sums = 00f677401a92d91568a4faffb4977ab71a32a265de59e35419ad5b705d4a532d
pkgname = ocaml-menhir-compcert
diff --git a/PKGBUILD b/PKGBUILD
index f0a4c9461409..a03e3f24c126 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,28 +8,28 @@
pkgname=ocaml-menhir-compcert
_basepkgname=${pkgname%-*}
-pkgver=20190924
+pkgver=20200211
pkgrel=1
pkgdesc="Latest version of Menhir that can build the latest CompCert release."
arch=("i686" "x86_64")
url="http://cristal.inria.fr/~fpottier/menhir/"
license=('GPL' 'QPL')
depends=('ocaml>=4.02')
-makedepends=('ocamlbuild' 'ocaml-findlib')
+makedepends=('ocamlbuild' 'ocaml-findlib' 'dune')
provides=($_basepkgname=$pkgver)
conflicts=($_basepkgname)
options=(!strip !makeflags)
source=("https://gitlab.inria.fr/fpottier/menhir/-/archive/$pkgver/menhir-$pkgver.tar.gz")
-md5sums=('69b2cbcfb12ca0ca09ad0096c8716265')
+sha256sums=('00f677401a92d91568a4faffb4977ab71a32a265de59e35419ad5b705d4a532d')
build() {
cd "$srcdir/${_basepkgname/ocaml-/}-$pkgver"
- make PREFIX="/usr" all
+
+ dune build
}
package() {
cd "$srcdir/${_basepkgname/ocaml-/}-$pkgver"
- export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- install -dm 755 "$OCAMLFIND_DESTDIR"
- make PREFIX="$pkgdir/usr" install
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
}