summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-09-11 13:10:44 +0200
committerJakob Gahde2019-09-11 13:10:44 +0200
commit3da80097f707d63458aca19a6f7df4b1db9aa0d1 (patch)
treef9a7fa0ba46ca611f1d9aa2d715671d5224b8b31
parent4affa19b98d041b58f9f720834f61f1d1ab6542d (diff)
downloadaur-3da80097f707d63458aca19a6f7df4b1db9aa0d1.tar.gz
ocaml-migrate-parsetree 1.4.0-1: Update to new version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c794929ef336..ad338bec2d77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = ocaml-migrate-parsetree
pkgdesc = Convert OCaml parsetrees between different versions
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/ocaml-ppx/ocaml-migrate-parsetree
arch = i686
arch = x86_64
- license = BSD
+ license = custom:LGPL2.1 with linking exception
makedepends = dune
depends = ocaml
depends = ocaml-result
depends = ocaml-ppx_derivers
options = !strip
- source = https://github.com/ocaml-ppx/ocaml-migrate-parsetree/releases/download/v1.3.1/ocaml-migrate-parsetree-v1.3.1.tbz
- sha512sums = 7da86f9596dd1439990a6f087fdeba64a0f3ce2634473be4cca92ecc02b6fcd97917956890fbe35b3cba5a126d007afec6ede1e4afd0a5218c89fd6079ad4182
+ source = https://github.com/ocaml-ppx/ocaml-migrate-parsetree/releases/download/v1.4.0/ocaml-migrate-parsetree-v1.4.0.tbz
+ sha512sums = 61ee91d2d146cc2d2ff2d5dc4ef5dea4dc4d3c8dbd8b4c9586d64b6ad7302327ab35547aa0a5b0103c3f07b66b13d416a1bee6d4d117293cd3cabe44113ec6d4
pkgname = ocaml-migrate-parsetree
diff --git a/PKGBUILD b/PKGBUILD
index c1da45c43b71..067622f3c6da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-migrate-parsetree
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="Convert OCaml parsetrees between different versions"
arch=('i686' 'x86_64')
-license=('BSD')
+license=('custom:LGPL2.1 with linking exception')
url="https://github.com/ocaml-ppx/ocaml-migrate-parsetree"
depends=('ocaml' 'ocaml-result' 'ocaml-ppx_derivers')
makedepends=('dune')
options=('!strip')
source=("https://github.com/ocaml-ppx/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tbz")
-sha512sums=('7da86f9596dd1439990a6f087fdeba64a0f3ce2634473be4cca92ecc02b6fcd97917956890fbe35b3cba5a126d007afec6ede1e4afd0a5218c89fd6079ad4182')
+sha512sums=('61ee91d2d146cc2d2ff2d5dc4ef5dea4dc4d3c8dbd8b4c9586d64b6ad7302327ab35547aa0a5b0103c3f07b66b13d416a1bee6d4d117293cd3cabe44113ec6d4')
build() {
cd "${srcdir}/${pkgname}-v${pkgver}"
- dune build
+ dune build --profile release
}
package() {
cd "${srcdir}/${pkgname}-v${pkgver}"
- install -dm755 "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ dune install --destdir "${pkgdir}"
install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}