summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2020-01-31 15:21:12 +0100
committerJakob Gahde2020-01-31 15:21:12 +0100
commitd6657c668f648e3bbe8c061f1c00e3cf6f0c5059 (patch)
tree88a9d9aaa6ac3b1b45a2ace0aada4b625a4ee4b5
parent3da80097f707d63458aca19a6f7df4b1db9aa0d1 (diff)
downloadaur-d6657c668f648e3bbe8c061f1c00e3cf6f0c5059.tar.gz
ocaml-migrate-parsetree 1.5.0-1: Update to new version
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad338bec2d77..35b1a66016d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = ocaml-migrate-parsetree
pkgdesc = Convert OCaml parsetrees between different versions
- pkgver = 1.4.0
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/ocaml-ppx/ocaml-migrate-parsetree
arch = i686
arch = x86_64
license = custom:LGPL2.1 with linking exception
makedepends = dune
+ depends = glibc
depends = ocaml
depends = ocaml-result
depends = ocaml-ppx_derivers
options = !strip
- source = https://github.com/ocaml-ppx/ocaml-migrate-parsetree/releases/download/v1.4.0/ocaml-migrate-parsetree-v1.4.0.tbz
- sha512sums = 61ee91d2d146cc2d2ff2d5dc4ef5dea4dc4d3c8dbd8b4c9586d64b6ad7302327ab35547aa0a5b0103c3f07b66b13d416a1bee6d4d117293cd3cabe44113ec6d4
+ source = https://github.com/ocaml-ppx/ocaml-migrate-parsetree/releases/download/v1.5.0/ocaml-migrate-parsetree-v1.5.0.tbz
+ sha512sums = 87fdccafae83b0437f1ccd4f3cfbc49e699bc0804596480e0df88510ba33410f31d48c7f677fe72800ed3f442a3a586d82d86aee1d12a964f79892833847b16a
pkgname = ocaml-migrate-parsetree
diff --git a/PKGBUILD b/PKGBUILD
index 067622f3c6da..dc175d0025c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-migrate-parsetree
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=1
pkgdesc="Convert OCaml parsetrees between different versions"
arch=('i686' 'x86_64')
license=('custom:LGPL2.1 with linking exception')
url="https://github.com/ocaml-ppx/ocaml-migrate-parsetree"
-depends=('ocaml' 'ocaml-result' 'ocaml-ppx_derivers')
+depends=('glibc' 'ocaml' 'ocaml-result' 'ocaml-ppx_derivers')
makedepends=('dune')
options=('!strip')
-source=("https://github.com/ocaml-ppx/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tbz")
-sha512sums=('61ee91d2d146cc2d2ff2d5dc4ef5dea4dc4d3c8dbd8b4c9586d64b6ad7302327ab35547aa0a5b0103c3f07b66b13d416a1bee6d4d117293cd3cabe44113ec6d4')
+source=("https://github.com/ocaml-ppx/ocaml-migrate-parsetree/releases/download/v${pkgver}/ocaml-migrate-parsetree-v${pkgver}.tbz")
+sha512sums=('87fdccafae83b0437f1ccd4f3cfbc49e699bc0804596480e0df88510ba33410f31d48c7f677fe72800ed3f442a3a586d82d86aee1d12a964f79892833847b16a')
build() {
- cd "${srcdir}/${pkgname}-v${pkgver}"
+ cd "${srcdir}/ocaml-migrate-parsetree-v${pkgver}"
- dune build --profile release
+ dune build -p ocaml-migrate-parsetree
}
package() {
- cd "${srcdir}/${pkgname}-v${pkgver}"
+ cd "${srcdir}/ocaml-migrate-parsetree-v${pkgver}"
dune install --destdir "${pkgdir}"
install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"