summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-27 23:28:22 +0100
committerGianluca Boiano2021-02-27 23:28:22 +0100
commit00fea49d0b37829fd25e1ccf8094883e2427b88b (patch)
tree43db10a0d61fc3b306ecc01c64c828139733f9f0
parent762928a8b7f8796fd93ccd77e12362e67f4ad875 (diff)
downloadaur-00fea49d0b37829fd25e1ccf8094883e2427b88b.tar.gz
ocaml-mm: 0.5.1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb9fe8214378..63c38cf0b604 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = ocaml-mm
arch = i686
arch = x86_64
license = custom:LGPL2.1 with linking exception
- makedepends = dune
+ makedepends = ocaml-findlib
depends = ocaml
depends = ocaml-alsa
depends = ocaml-ao
diff --git a/PKGBUILD b/PKGBUILD
index 6b5f371453f5..6f236691e60e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,19 +10,24 @@ arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-mm"
license=('custom:LGPL2.1 with linking exception')
depends=('ocaml' 'ocaml-alsa' 'ocaml-ao' 'ocaml-pulseaudio' 'ocaml-gstreamer' 'ocaml-mad' 'ocaml-ogg' 'ocaml-ocamlsdl' 'ocaml-theora' 'ffmpeg')
-makedepends=('dune')
+makedepends=('ocaml-findlib')
options=('!strip')
source=("https://github.com/savonet/ocaml-mm/archive/v${pkgver}.tar.gz")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- dune build
+ ./bootstrap
+ ./configure
+ make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+
}
sha256sums=('d03ed076bd084d19a9a747d129066c579b15915db9400d50e161ec09e03bf069')