summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-27 23:21:08 +0100
committerGianluca Boiano2021-02-27 23:21:08 +0100
commit762928a8b7f8796fd93ccd77e12362e67f4ad875 (patch)
tree4ec4a90065063a39484b9ade597e6946adb5a955
parentac61932706309b070faa770668a262ef76ff6725 (diff)
downloadaur-762928a8b7f8796fd93ccd77e12362e67f4ad875.tar.gz
ocaml-mm: 0.5.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d838318928a4..cb9fe8214378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ocaml-mm
pkgdesc = OCaml multimedia library
- pkgver = 0.5.0
- pkgrel = 2
+ pkgver = 0.5.1
+ pkgrel = 1
url = https://github.com/savonet/ocaml-mm
arch = i686
arch = x86_64
license = custom:LGPL2.1 with linking exception
- makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml
depends = ocaml-alsa
depends = ocaml-ao
@@ -18,8 +18,8 @@ pkgbase = ocaml-mm
depends = ocaml-theora
depends = ffmpeg
options = !strip
- source = https://github.com/savonet/ocaml-mm/releases/download/0.5.0/ocaml-mm-0.5.0.tar.gz
- sha512sums = 8c252471430496aa9df70986bfbcc79b927367879b926de3fb0f02f6998752dd321b3956a9a2eb238af78740fdd5f406d7a16e616a72030b1e131163c0f4482c
+ source = https://github.com/savonet/ocaml-mm/archive/v0.5.1.tar.gz
+ sha256sums = d03ed076bd084d19a9a747d129066c579b15915db9400d50e161ec09e03bf069
pkgname = ocaml-mm
diff --git a/PKGBUILD b/PKGBUILD
index bf70cd555223..6b5f371453f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: robertfoster
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-mm
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.5.1
+pkgrel=1
pkgdesc="OCaml multimedia library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-mm"
license=('custom:LGPL2.1 with linking exception')
depends=('ocaml' 'ocaml-alsa' 'ocaml-ao' 'ocaml-pulseaudio' 'ocaml-gstreamer' 'ocaml-mad' 'ocaml-ogg' 'ocaml-ocamlsdl' 'ocaml-theora' 'ffmpeg')
-makedepends=('ocaml-findlib')
+makedepends=('dune')
options=('!strip')
-source=("https://github.com/savonet/ocaml-mm/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('8c252471430496aa9df70986bfbcc79b927367879b926de3fb0f02f6998752dd321b3956a9a2eb238af78740fdd5f406d7a16e616a72030b1e131163c0f4482c')
+source=("https://github.com/savonet/ocaml-mm/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
}
+
+sha256sums=('d03ed076bd084d19a9a747d129066c579b15915db9400d50e161ec09e03bf069')