summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-09-11 13:42:33 +0200
committerJakob Gahde2019-09-11 13:42:33 +0200
commit09931777d1ab4cca3e37d1a869ff1c4bd527f82c (patch)
tree621fe9ea83d64775a30253c405963dfe1c14438a
downloadaur-09931777d1ab4cca3e37d1a869ff1c4bd527f82c.tar.gz
ocaml-mmap 1.1.0-1: Create new package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63917a3357a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ocaml-mmap
+ pkgdesc = Provides a Mmap.map_file functions for mapping files in memory
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/mirage/mmap
+ arch = x86_64
+ license = custom:LGPL2.1 with linking exception
+ makedepends = dune
+ depends = ocaml
+ source = https://github.com/mirage/mmap/releases/download/v1.1.0/mmap-v1.1.0.tbz
+ sha512sums = 15e4ec2634998f321f495de5372dc75a3f4059ab7512115603ae8fd99a619c91299d34c8a12a697aa36df4ce14c90c66746b873eddf004b7bbbeaef8ec7858f5
+
+pkgname = ocaml-mmap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b3c16f63666
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-mmap
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Provides a Mmap.map_file functions for mapping files in memory"
+arch=('x86_64')
+url="https://github.com/mirage/mmap"
+license=('custom:LGPL2.1 with linking exception')
+depends=('ocaml')
+makedepends=('dune')
+source=("https://github.com/mirage/mmap/releases/download/v${pkgver}/mmap-v${pkgver}.tbz")
+sha512sums=('15e4ec2634998f321f495de5372dc75a3f4059ab7512115603ae8fd99a619c91299d34c8a12a697aa36df4ce14c90c66746b873eddf004b7bbbeaef8ec7858f5')
+
+build() {
+ cd "${srcdir}/mmap-v${pkgver}"
+
+ dune build --profile release
+}
+
+
+package() {
+ cd "${srcdir}/mmap-v${pkgver}"
+
+ dune install --destdir "${pkgdir}"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}