summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-09-11 14:20:38 +0200
committerJakob Gahde2019-09-11 14:20:38 +0200
commit9abcf38fcc997cfc841a8ddba594348d0272d75b (patch)
tree60f4f61acb43e91949186dc1eaf8dffce7d6e7c5
downloadaur-9abcf38fcc997cfc841a8ddba594348d0272d75b.tar.gz
ocaml-ocplib-endian 1.0-1: Create new package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b529ff47a52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ocaml-ocplib-endian
+ pkgdesc = Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.typerex.org/ocplib-endian.html
+ arch = x86_64
+ license = custom:LGPL2.1 with linking exception
+ makedepends = ocaml-findlib
+ makedepends = ocamlbuild
+ makedepends = cppo
+ depends = ocaml
+ source = https://github.com/OCamlPro/ocplib-endian/archive/1.0.tar.gz
+ sha512sums = a08fd58ec5e72510c40e8b75e0ee8327ee658f479e45dd4632bc04e3907d04aaa3684df3b993ab63fc2a6c1f1a4fb32784e9b5258730d3b89a716300522d8d7f
+
+pkgname = ocaml-ocplib-endian
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcb40379d72c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ocplib-endian
+pkgver=1.0
+pkgrel=1
+pkgdesc="Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays"
+arch=('x86_64')
+url="https://www.typerex.org/ocplib-endian.html"
+license=('custom:LGPL2.1 with linking exception')
+depends=('ocaml')
+makedepends=('ocaml-findlib' 'ocamlbuild' 'cppo')
+source=("https://github.com/OCamlPro/ocplib-endian/archive/${pkgver}.tar.gz")
+sha512sums=('a08fd58ec5e72510c40e8b75e0ee8327ee658f479e45dd4632bc04e3907d04aaa3684df3b993ab63fc2a6c1f1a4fb32784e9b5258730d3b89a716300522d8d7f')
+
+build() {
+ cd "${srcdir}/ocplib-endian-${pkgver}"
+
+ ./configure --disable-debug
+ make build
+}
+
+
+package() {
+ cd "${srcdir}/ocplib-endian-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ install -dm755 "${OCAMLFIND_DESTDIR}"
+ make install
+ install -Dm644 "COPYING.txt" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.txt"
+}