summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-14 20:34:56 +0200
committerDaniel Peukert2022-06-14 20:34:56 +0200
commitee98cc36d8968bc8dedd1b61f603d81765833360 (patch)
tree075845f6de3da91a155aaa54181241a06603c7e9
parent100073902e1981c0e336c4ca13a9f63459601c83 (diff)
downloadaur-ee98cc36d8968bc8dedd1b61f603d81765833360.tar.gz
Fix dun calls, sha256 -> sha512
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3147a8029b0..5d658258a683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ocplib-endian
pkgdesc = Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays
pkgver = 1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OCamlPro/ocplib-endian
arch = x86_64
arch = i686
@@ -14,7 +14,7 @@ pkgbase = ocaml-ocplib-endian
makedepends = dune>=1.0.0
depends = ocaml>=4.03.0
options = !strip
- source = ocaml-ocplib-endian-1.2-1.tar.gz::https://github.com/OCamlPro/ocplib-endian/archive/1.2.tar.gz
+ source = ocaml-ocplib-endian-1.2-2.tar.gz::https://github.com/OCamlPro/ocplib-endian/archive/1.2.tar.gz
sha512sums = 2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85
pkgname = ocaml-ocplib-endian
diff --git a/PKGBUILD b/PKGBUILD
index 146f0289afb3..5dc46ec12c5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='ocplib-endian'
pkgname="ocaml-$_projectname"
pkgver='1.2'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/OCamlPro/$_projectname"
@@ -28,11 +28,7 @@ check() {
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
-
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -Dm644 'COPYING.txt' "$pkgdir/usr/share/doc/$pkgname/COPYING.txt"