summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2019-04-23 20:08:38 +0100
committerEarnestly2019-04-23 20:08:38 +0100
commitea29fb9fa81eaa7100c979a6a9aa2c3db91259d7 (patch)
treef488eb7c22b0d540f66afed80c087a4afe642502
parente9eb3aca7ef3dbbeccbe1c76667f59a953598cc6 (diff)
downloadaur-ea29fb9fa81eaa7100c979a6a9aa2c3db91259d7.tar.gz
makefile patch no longer needed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--fix-makefile-install-target.diff25
3 files changed, 6 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18172904b8f6..c77abf4adc95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-ocplib-simplex-git
pkgdesc = simplex algorithm implementation for solving systems of linear inequalities and optimizing linear objective functions
- pkgver = r38.g5bee435
+ pkgver = 0.4.r4.gd52771f
pkgrel = 1
url = https://github.com/OCamlPro-Iguernlala/ocplib-simplex
arch = i686
@@ -12,9 +12,7 @@ pkgbase = ocaml-ocplib-simplex-git
provides = ocaml-ocplib-simplex
conflicts = ocaml-ocplib-simplex
source = git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex
- source = fix-makefile-install-target.diff
sha256sums = SKIP
- sha256sums = 273455a20fd9a291956904fe48734d2e602ab07211d6833968f5ca0ecc271a31
pkgname = ocaml-ocplib-simplex-git
diff --git a/PKGBUILD b/PKGBUILD
index bd0b81a1e1aa..e9f6ef1be882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=ocaml-ocplib-simplex-git
-pkgver=r38.g5bee435
+pkgver=0.4.r4.gd52771f
pkgrel=1
pkgdesc='simplex algorithm implementation for solving systems of linear inequalities and optimizing linear objective functions'
@@ -13,21 +13,13 @@ makedepends=('ocaml-findlib' 'git')
provides=('ocaml-ocplib-simplex')
conflicts=('ocaml-ocplib-simplex')
-source=('git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex'
- 'fix-makefile-install-target.diff')
+source=('git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex')
-sha256sums=('SKIP'
- '273455a20fd9a291956904fe48734d2e602ab07211d6833968f5ca0ecc271a31')
-
-prepare() {
- cd ocplib-simplex
- # https://github.com/OCamlPro-Iguernlala/ocplib-simplex/issues/6
- patch -Np1 -i "$srcdir"/fix-makefile-install-target.diff
-}
+sha256sums=('SKIP')
pkgver() {
cd ocplib-simplex
- printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed -r 's/^v//; s/([^-]*-g)/r\1/; s/-/./g'
}
build() {
@@ -45,5 +37,5 @@ check() {
package() {
cd ocplib-simplex
- make DESTDIR="$pkgdir" install
+ make LIBDIR="$(ocamlc -where)" DESTDIR="$pkgdir" install
}
diff --git a/fix-makefile-install-target.diff b/fix-makefile-install-target.diff
deleted file mode 100644
index 0d4bb5da2553..000000000000
--- a/fix-makefile-install-target.diff
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/Makefile.in b/Makefile.in
-index 3c5cf07..3642dc2 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -13,11 +13,10 @@
- # (enclosed in the file LGPL).
-
- # where to install the binaries
--DESTDIR=@prefix@
- # prefix=@prefix@
- # exec_prefix=@exec_prefix@
- # BINDIR=$(DESTDIR)@bindir@
--LIBDIR=$(DESTDIR)/lib/
-+LIBDIR ?= $(shell @OCAMLC@ -where)
- # DATADIR=$(DESTDIR)@datadir@/ocplib-simplex
-
- # where to install the man page
-@@ -112,7 +111,8 @@ META: config.status
- ##############
-
- install: all META
-- OCAMLFIND_DESTDIR=$(LIBDIR) \
-+ install -dm0755 $(DESTDIR)$(LIBDIR)/ocplib-simplex
-+ OCAMLFIND_DESTDIR=$(DESTDIR)$(LIBDIR) \
- ocamlfind install ocplib-simplex src/$(LIBNAME).* src/*.mli META