summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-02-03 20:24:30 +0100
committerDaniel Peukert2020-02-03 20:24:30 +0100
commitb0b0e4d51fe053c6c30b311942ed492219fdabe0 (patch)
tree78f7c17ecbbf98282906c5895bed8ce0282e8aca
parentceda4e103cfc40d234b48956727c76483c82b0ad (diff)
downloadaur-b0b0e4d51fe053c6c30b311942ed492219fdabe0.tar.gz
Updated ocaml packages to use the release profile
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 192bf8ef2996..f13a985b3d3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ounit
pkgdesc = Unit testing framework for OCaml
pkgver = 2.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gildor478/ounit
arch = x86_64
arch = i686
@@ -12,7 +12,7 @@ pkgbase = ocaml-ounit
depends = ocaml-lwt
depends = ocaml-stdlib-shims
options = !strip
- source = ocaml-ounit-2.2.2-1.tar.gz::https://github.com/gildor478/ounit/archive/v2.2.2.tar.gz
+ source = ocaml-ounit-2.2.2-2.tar.gz::https://github.com/gildor478/ounit/archive/v2.2.2.tar.gz
sha256sums = db5dbdd4fd29a9ff82dd9d75813e0391d833ba868f813e3c3349807bc9da5032
pkgname = ocaml-ounit
diff --git a/PKGBUILD b/PKGBUILD
index 95370f3e6ca9..d5c4920d2e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_projectname='ounit'
pkgname="ocaml-$_projectname"
pkgver='2.2.2'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Unit testing framework for OCaml'
arch=('x86_64' 'i686')
url="https://github.com/gildor478/$_projectname"
@@ -25,12 +25,12 @@ _sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build
+ dune build -p "${_projectname},${_projectname}-lwt,${_projectname}2,${_projectname}2-lwt" --verbose
}
check() {
cd "$srcdir/$_sourcedirectory/"
- dune runtest
+ dune runtest -p "${_projectname},${_projectname}-lwt,${_projectname}2,${_projectname}2-lwt" --verbose
}
package() {