summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-03 16:26:35 +0200
committerJ5lx2015-07-03 16:26:35 +0200
commit0faf30cd2473cbe104b0f5c22370a549812d515c (patch)
treef1f220537311aee7935268b15656a2811ed45d5e
downloadaur-0faf30cd2473cbe104b0f5c22370a549812d515c.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a99fb87f3a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ocaml-pa_bench
+ pkgdesc = Syntax extension for inline benchmarks
+ pkgver = 112.06.00
+ pkgrel = 1
+ url = https://github.com/janestreet/pa_bench
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-pa_ounit
+ depends = ocaml-type_conv
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/112.06.00/individual/pa_bench-112.06.00.tar.gz
+ md5sums = c270ccea47f83bf2a9206d1fa502c02e
+
+pkgname = ocaml-pa_bench
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c38aea9c5f7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-pa_bench
+pkgver=112.06.00
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="Syntax extension for inline benchmarks"
+url="https://github.com/janestreet/pa_bench"
+depends=('ocaml' 'ocaml-pa_ounit' 'ocaml-type_conv')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/${pkgver}/individual/${pkgname#ocaml-}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('c270ccea47f83bf2a9206d1fa502c02e')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR"
+ DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
+ make install
+}