summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 16:36:19 +0200
committerJakob Gahde2018-06-28 16:36:19 +0200
commit1315efdf644d5772a5f4235a6510ca1e26dc1f54 (patch)
tree134e96af5d405c6046c7cc29d395dce5d1520355
downloadaur-1315efdf644d5772a5f4235a6510ca1e26dc1f54.tar.gz
ocaml-parsexp 0.11.0-1: New package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1f2d363c024
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 14:36:02 UTC 2018
+pkgbase = ocaml-parsexp
+ pkgdesc = S-expression parsing library
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/janestreet/parsexp
+ arch = x86_64
+ license = Apache
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-sexplib0
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/parsexp-v0.11.0.tar.gz
+ md5sums = 816fce8d14b71a379296577c803bdbca
+
+pkgname = ocaml-parsexp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3333f22aa94d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-parsexp
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="S-expression parsing library"
+arch=('x86_64')
+url='https://github.com/janestreet/parsexp'
+license=('Apache')
+depends=('ocaml' 'ocaml-sexplib0')
+makedepends=('dune')
+options=('!strip')
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/parsexp-v${pkgver}.tar.gz")
+md5sums=('816fce8d14b71a379296577c803bdbca')
+
+build() {
+ cd "${srcdir}/parsexp-v${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/parsexp-v${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}