summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:14:40 +0200
committerDaniel Peukert2020-06-02 00:14:40 +0200
commit5fbef1a044c9ff40cfa8fee040aaf470abbbaf81 (patch)
tree242d299463c2a8ef801780f49ffa97b5c793c99c
parent6e10504c4ca39bb319db91e1e14131aaa18dad87 (diff)
downloadaur-5fbef1a044c9ff40cfa8fee040aaf470abbbaf81.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fcf62d48058..f5b0183048d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-parsexp
pkgdesc = S-expression parsing library
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
url = https://github.com/janestreet/parsexp
arch = x86_64
arch = i686
@@ -10,12 +10,12 @@ pkgbase = ocaml-parsexp
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-base>=0.13.0
- depends = ocaml-sexplib0>=0.13.0
+ depends = ocaml-base>=0.14.0
+ depends = ocaml-sexplib0>=0.14.0
options = !strip
- source = ocaml-parsexp-0.13.0-2.tar.gz::https://github.com/janestreet/parsexp/archive/v0.13.0.tar.gz
- sha256sums = 1e52717656f82b4463df2a2bced0f8b390960992bf4496b2b67e0229b516af12
+ source = ocaml-parsexp-0.14.0-1.tar.gz::https://github.com/janestreet/parsexp/archive/v0.14.0.tar.gz
+ sha256sums = 6ede506ea367a96b2f128dbc676199d055f547adb4d96605bac624f10d62b256
pkgname = ocaml-parsexp
diff --git a/PKGBUILD b/PKGBUILD
index 6fc69b4538a6..b7f26c96d37d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='parsexp'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
pkgdesc='S-expression parsing library'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-sexplib0>=0.13.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-sexplib0>=0.14.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1e52717656f82b4463df2a2bced0f8b390960992bf4496b2b67e0229b516af12')
+sha256sums=('6ede506ea367a96b2f128dbc676199d055f547adb4d96605bac624f10d62b256')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"