summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-09-10 00:25:37 +0200
committerJakob Gahde2019-09-10 00:25:37 +0200
commit9143db40adf1493a2a245331e0496352e6b2e733 (patch)
treec0fc90c83ebf2e6fdb34ca1815836f45136ebe5c
parent1315efdf644d5772a5f4235a6510ca1e26dc1f54 (diff)
downloadaur-9143db40adf1493a2a245331e0496352e6b2e733.tar.gz
ocaml-parsexp 0.12.0-1: Update to new version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1f2d363c024..53bb13eab6f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 14:36:02 UTC 2018
pkgbase = ocaml-parsexp
pkgdesc = S-expression parsing library
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/janestreet/parsexp
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
+ depends = ocaml-base
depends = ocaml-sexplib0
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/parsexp-v0.11.0.tar.gz
- md5sums = 816fce8d14b71a379296577c803bdbca
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/parsexp-v0.12.0.tar.gz
+ sha512sums = 849968ac69709b293208fabde5cc22972a3def3ed35517e571c5127b417c7129a0d9eafc94fd580508203b611a9614b2612670dbdf69887b0e71f7cc5278bf12
pkgname = ocaml-parsexp
diff --git a/PKGBUILD b/PKGBUILD
index 3333f22aa94d..281c6159edd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-parsexp
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
pkgdesc="S-expression parsing library"
arch=('x86_64')
-url='https://github.com/janestreet/parsexp'
-license=('Apache')
-depends=('ocaml' 'ocaml-sexplib0')
+url="https://github.com/janestreet/parsexp"
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-sexplib0')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/parsexp-v${pkgver}.tar.gz")
-md5sums=('816fce8d14b71a379296577c803bdbca')
+sha512sums=('849968ac69709b293208fabde5cc22972a3def3ed35517e571c5127b417c7129a0d9eafc94fd580508203b611a9614b2612670dbdf69887b0e71f7cc5278bf12')
build() {
cd "${srcdir}/parsexp-v${pkgver}"
- jbuilder build
+ dune build --profile release
}
package() {
cd "${srcdir}/parsexp-v${pkgver}"
- mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ dune install --destdir "${pkgdir}"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}