summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-11-05 09:48:11 +0100
committerJakob Gahde2016-11-05 09:48:11 +0100
commitb802028a1429d0ffcb21e35fb4284cf01111650d (patch)
tree641d28e1b4a7cd0d8ddd7240dac3bd46585371c9
parent4778f2173665cbcbf8a35fd559256ce52e396053 (diff)
downloadaur-b802028a1429d0ffcb21e35fb4284cf01111650d.tar.gz
ocaml-pcre 7.2.3-2: Update dependencies after ocamlbuild became a separate package
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cd98df46049..eb27ed0c0a1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Mar 23 10:50:54 UTC 2016
+# Sat Nov 5 08:47:36 UTC 2016
pkgbase = ocaml-pcre
pkgdesc = Perl compatible regular expressions for OCaml
pkgver = 7.2.3
- pkgrel = 1
+ pkgrel = 2
url = http://mmottl.github.io/pcre-ocaml
arch = i686
arch = x86_64
license = LGPL
makedepends = ocaml-findlib
+ makedepends = ocamlbuild
depends = pcre>=4.5
conflicts = pcre-ocaml
replaces = pcre-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index 2ac9dddc54d1..482590193d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgname=ocaml-pcre
pkgver=7.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Perl compatible regular expressions for OCaml"
arch=('i686' 'x86_64')
url="http://mmottl.github.io/pcre-ocaml"
license=('LGPL')
depends=('pcre>=4.5')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'ocamlbuild')
replaces=('pcre-ocaml')
conflicts=('pcre-ocaml')
options=('!strip' 'staticlibs')
@@ -30,8 +30,8 @@ package() {
cd "${srcdir}/pcre-ocaml-${pkgver}"
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- install -dm 755 "${OCAMLFIND_DESTDIR}/stublibs"
+ install -dm755 "${OCAMLFIND_DESTDIR}/stublibs"
make install
mv "${pkgdir}/usr/share/doc/pcre" "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm 644 COPYING.txt "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 COPYING.txt "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}