summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-15 10:27:40 +0200
committerJakob Gahde2019-05-15 10:27:40 +0200
commitd2685e97230bc453656b34ce9152b2b78b2133cb (patch)
tree86026049040ca4e3140469c1fa8511298e9674e1
parent38c82f978057421ba5c229ba8157407bc511da76 (diff)
downloadaur-d2685e97230bc453656b34ce9152b2b78b2133cb.tar.gz
ocaml-ppx_assert 1:0.12.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e73f7a2d1335..f74413f5895c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 14:09:41 UTC 2018
pkgbase = ocaml-ppx_assert
pkgdesc = Assert-like extension nodes that raise useful errors on failure
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_assert
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
depends = ocaml-ppx_compare
depends = ocaml-ppx_here
depends = ocaml-ppx_sexp_conv
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_assert-v0.11.0.tar.gz
- md5sums = 0b3aed19391e9a23217a5abf022dfe10
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_assert-v0.12.0.tar.gz
+ sha512sums = 4ebc62572f945ebe583c7392120b38cd723b292162dbc7f20293fab8877c6139a9cad7d3439204ded3f013cc5a53137594b4e1c11ad56d8a089459f739a71ed9
pkgname = ocaml-ppx_assert
diff --git a/PKGBUILD b/PKGBUILD
index 3d380729ebd7..1ec84a593906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_assert
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Assert-like extension nodes that raise useful errors on failure"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_assert"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip' '!emptydirs')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_assert-v${pkgver}.tar.gz")
-md5sums=('0b3aed19391e9a23217a5abf022dfe10')
+sha512sums=('4ebc62572f945ebe583c7392120b38cd723b292162dbc7f20293fab8877c6139a9cad7d3439204ded3f013cc5a53137594b4e1c11ad56d8a089459f739a71ed9')
build() {
cd "${srcdir}/ppx_assert-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_assert-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}