summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 13:35:36 +0200
committerJakob Gahde2016-07-29 13:35:36 +0200
commitfc514eaa00eb7d9ea047aad29ef97a9ecf7d357d (patch)
tree82b5111d44fa591385ed78891c8292ec7070ed3c
parentb3592c4fd3ff3d1a506e6b24b796a7dbc3fe13ed (diff)
downloadaur-fc514eaa00eb7d9ea047aad29ef97a9ecf7d357d.tar.gz
ocaml-ppx_assert 113.33.03-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--exedir.patch10
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 695b002fb807..56b8928542c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 02:17:23 UTC 2016
+# Fri Jul 29 11:35:12 UTC 2016
pkgbase = ocaml-ppx_assert
pkgdesc = Assert-like extension nodes that raise useful errors on failure
- pkgver = 113.24.00
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/ppx_assert
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-ppx_compare
@@ -20,10 +21,13 @@ pkgbase = ocaml-ppx_assert
depends = ocaml-ppx_type_conv
depends = ocaml-sexplib
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/ppx_assert-113.24.00.tar.gz
+ options = !emptydirs
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_assert-113.33.03.tar.gz
source = libdir.patch
- md5sums = 780dd113fa9bf28179b2e2a4a2d82ebe
+ source = exedir.patch
+ md5sums = 4da98302d2827397b6330451d44cd3e2
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
+ md5sums = 3f9ce9a72b72a54df6c1b54cdd24b110
pkgname = ocaml-ppx_assert
diff --git a/PKGBUILD b/PKGBUILD
index 0f65c60323e4..2778926a1a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_assert
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Assert-like extension nodes that raise useful errors on failure"
url="https://github.com/janestreet/ppx_assert"
depends=('ocaml' 'ocaml-ppx_compare' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools' 'ocaml-ppx_type_conv' 'ocaml-sexplib')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('780dd113fa9bf28179b2e2a4a2d82ebe'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('4da98302d2827397b6330451d44cd3e2'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ '3f9ce9a72b72a54df6c1b54cdd24b110')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {
diff --git a/exedir.patch b/exedir.patch
new file mode 100644
index 000000000000..2c8acfc550c6
--- /dev/null
+++ b/exedir.patch
@@ -0,0 +1,10 @@
+diff -aur package.pristine/install.ml package.new/install.ml
+--- package.pristine/install.ml 2016-07-29 13:32:19.341223767 +0200
++++ package.new/install.ml 2016-07-29 13:32:33.834459844 +0200
+@@ -7,5 +7,5 @@
+ [ oasis_lib "ppx_assert"
+ ; oasis_lib "ppx_assert_lib"
+ ; file "META" ~section:"lib"
+- ; oasis_exe "ppx" ~dest:"../lib/ppx_assert/ppx"
++ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_assert/ppx"
+ ]