summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-05-23 20:55:48 +0200
committerDaniel Peukert2023-05-23 20:55:48 +0200
commit9f950416873c631115b34f9fd9d99a3fea0f2eff (patch)
tree6a0bf878f4b9fb72428bd7a5f6b46c527b3e085b
parentbaf7030cd6dad09c04a1b94d528c30b4551e4ee8 (diff)
downloadaur-9f950416873c631115b34f9fd9d99a3fea0f2eff.tar.gz
Update janestreet packages to 0.16.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD12
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2a12704fdf7..277b82b3a006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = ocaml-ppx_base
pkgdesc = Base set of ppx rewriters
- pkgver = 0.15.0
- pkgrel = 4
+ pkgver = 0.16.0
+ pkgrel = 1
url = https://github.com/janestreet/ppx_base
arch = x86_64
- arch = i686
- arch = pentium4
- arch = armv7h
arch = aarch64
license = MIT
makedepends = dune>=2.0.0
- depends = ocaml>=4.08.0
- depends = ocaml-ppx_cold>=0.15.0
- depends = ocaml-ppx_compare>=0.15.0
- depends = ocaml-ppx_enumerate>=0.15.0
- depends = ocaml-ppx_hash>=0.15.0
- depends = ocaml-ppx_sexp_conv>=0.15.0
- depends = ocaml-ppxlib>=0.23.0
+ depends = ocaml>=4.14.0
+ depends = ocaml-ppx_cold>=0.16.0
+ depends = ocaml-ppx_compare>=0.16.0
+ depends = ocaml-ppx_enumerate>=0.16.0
+ depends = ocaml-ppx_globalize>=0.16.0
+ depends = ocaml-ppx_hash>=0.16.0
+ depends = ocaml-ppx_sexp_conv>=0.16.0
+ depends = ocaml-ppxlib>=0.28.0
options = !strip
- source = ocaml-ppx_base-0.15.0-4.tar.gz::https://github.com/janestreet/ppx_base/archive/v0.15.0.tar.gz
- sha512sums = 6843c496bde4e9bccab1a7169da373bf315c5c6a551fd3e71b9e2b589e1d3b9a6361ccf2130ebde4bcb10a6c07d2c25acbf9951463e4b18e91bf289ce04daf72
+ source = ocaml-ppx_base-0.16.0-1.tar.gz::https://github.com/janestreet/ppx_base/archive/v0.16.0.tar.gz
+ sha512sums = 110b03434f0ef7c82b8728c60ac03f56ec0bc2a292d9cc39bbca0102a976c34fb4a18311a7a1ff6755f7f61c2aa677d0413da36635f98336cc59eef962b8abb3
pkgname = ocaml-ppx_base
diff --git a/PKGBUILD b/PKGBUILD
index 0aed6b5326db..abfa2fd96ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_base'
pkgname="ocaml-$_projectname"
-pkgver='0.15.0'
-pkgrel='4'
+pkgver='0.16.0'
+pkgrel='1'
pkgdesc='Base set of ppx rewriters'
-# If you're running on i686, pentium4, armv7h or aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
-arch=('x86_64' 'i686' 'pentium4' 'armv7h' 'aarch64')
+# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
+arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.08.0' 'ocaml-ppx_cold>=0.15.0' 'ocaml-ppx_compare>=0.15.0' 'ocaml-ppx_enumerate>=0.15.0' 'ocaml-ppx_hash>=0.15.0' 'ocaml-ppx_sexp_conv>=0.15.0' 'ocaml-ppxlib>=0.23.0')
+depends=('ocaml>=4.14.0' 'ocaml-ppx_cold>=0.16.0' 'ocaml-ppx_compare>=0.16.0' 'ocaml-ppx_enumerate>=0.16.0' 'ocaml-ppx_globalize>=0.16.0' 'ocaml-ppx_hash>=0.16.0' 'ocaml-ppx_sexp_conv>=0.16.0' 'ocaml-ppxlib>=0.28.0')
makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('6843c496bde4e9bccab1a7169da373bf315c5c6a551fd3e71b9e2b589e1d3b9a6361ccf2130ebde4bcb10a6c07d2c25acbf9951463e4b18e91bf289ce04daf72')
+sha512sums=('110b03434f0ef7c82b8728c60ac03f56ec0bc2a292d9cc39bbca0102a976c34fb4a18311a7a1ff6755f7f61c2aa677d0413da36635f98336cc59eef962b8abb3')
_sourcedirectory="$_projectname-$pkgver"