summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-21 17:06:01 +0100
committerDaniel Peukert2020-03-21 17:06:01 +0100
commit4e4c28fc4bf1eae834e0f8d38d9a818e32d735fd (patch)
tree4df6212dd5170d156538bc24022bcc9bbf1ef3f8
parent69b6368e7cca222760dca042d48ff1768b52934f (diff)
downloadaur-4e4c28fc4bf1eae834e0f8d38d9a818e32d735fd.tar.gz
Added ocaml-ppx_bench and dependencies
-rw-r--r--.SRCINFO22
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD49
4 files changed, 61 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5433ae74f987..447e8f797c25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = ocaml-ppx_bench
pkgdesc = Syntax extension for writing in-line benchmarks in ocaml code
- pkgver = 0.12.0
+ pkgver = 0.13.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_bench
- arch = i686
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
- makedepends = dune
- depends = ocaml
- depends = ocaml-ppx_inline_test
- depends = ocaml-ppxlib
+ makedepends = dune>=1.5.1
+ depends = ocaml>=4.04.2
+ depends = ocaml-ppx_inline_test>=0.13.0
+ depends = ocaml-ppxlib>=0.9.0
options = !strip
- options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_bench-v0.12.0.tar.gz
- sha512sums = 0f89c0b17d873befc7f613bb3b09ec1dba5af046a918b1c64dd3e09fdc83e3e12f455103e330744e74f7ab6b122fe6f14d42d625dfc7fcaec48ab7821086c13e
+ source = ocaml-ppx_bench-0.13.0-1.tar.gz::https://github.com/janestreet/ppx_bench/archive/v0.13.0.tar.gz
+ sha256sums = b615d8f5ad057ab461972cfa198ed17a57c6703627360750826495390e429f28
pkgname = ocaml-ppx_bench
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 44f480228072..0c67a86e8941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ppx_bench
-pkgver=0.12.0
-pkgrel=1
-epoch=1
-pkgdesc="Syntax extension for writing in-line benchmarks in ocaml code"
-arch=('i686' 'x86_64')
-url="https://github.com/janestreet/ppx_bench"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppx_bench'
+pkgname="ocaml-$_projectname"
+pkgver='0.13.0'
+pkgrel='1'
+epoch='1'
+pkgdesc='Syntax extension for writing in-line benchmarks in ocaml code'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml' 'ocaml-ppx_inline_test' 'ocaml-ppxlib')
-makedepends=('dune')
-options=('!strip' '!emptydirs')
-source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_bench-v${pkgver}.tar.gz")
-sha512sums=('0f89c0b17d873befc7f613bb3b09ec1dba5af046a918b1c64dd3e09fdc83e3e12f455103e330744e74f7ab6b122fe6f14d42d625dfc7fcaec48ab7821086c13e')
+depends=('ocaml>=4.04.2' 'ocaml-ppx_inline_test>=0.13.0' 'ocaml-ppxlib>=0.9.0')
+makedepends=('dune>=1.5.1')
+options=('!strip')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('b615d8f5ad057ab461972cfa198ed17a57c6703627360750826495390e429f28')
-build() {
- cd "${srcdir}/ppx_bench-v${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- dune build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
package() {
- cd "${srcdir}/ppx_bench-v${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
- install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}