summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-15 14:17:55 +0200
committerJakob Gahde2019-05-15 14:17:55 +0200
commit69b6368e7cca222760dca042d48ff1768b52934f (patch)
treea2455a3d2fdc7ee350d89a718bd0072f93020e8b
parent9985cd170c82180066cf97b4c411d3d349b71b8a (diff)
downloadaur-69b6368e7cca222760dca042d48ff1768b52934f.tar.gz
ocaml-ppx_bench 1:0.12.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8059c5bb42e..5433ae74f987 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 15:42:30 UTC 2018
pkgbase = ocaml-ppx_bench
pkgdesc = Syntax extension for writing in-line benchmarks in ocaml code
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_bench
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-ppx_inline_test
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_bench-v0.11.0.tar.gz
- md5sums = a1565e9aa8e341f33e2e3dd712c889c8
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_bench-v0.12.0.tar.gz
+ sha512sums = 0f89c0b17d873befc7f613bb3b09ec1dba5af046a918b1c64dd3e09fdc83e3e12f455103e330744e74f7ab6b122fe6f14d42d625dfc7fcaec48ab7821086c13e
pkgname = ocaml-ppx_bench
diff --git a/PKGBUILD b/PKGBUILD
index 82b100190e7e..44f480228072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_bench
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Syntax extension for writing in-line benchmarks in ocaml code"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_bench"
-license=('Apache')
-depends=('ocaml' 'ocaml-ppx_inline_test' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-ppx_inline_test' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip' '!emptydirs')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_bench-v${pkgver}.tar.gz")
-md5sums=('a1565e9aa8e341f33e2e3dd712c889c8')
+sha512sums=('0f89c0b17d873befc7f613bb3b09ec1dba5af046a918b1c64dd3e09fdc83e3e12f455103e330744e74f7ab6b122fe6f14d42d625dfc7fcaec48ab7821086c13e')
build() {
cd "${srcdir}/ppx_bench-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_bench-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}