summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:15:15 +0200
committerDaniel Peukert2020-06-02 00:15:15 +0200
commitcbf7852414a9302de6c48b8bd63147ad9f1c6f09 (patch)
tree1b3ed24a839f4525d00088569b2083301a6a17ea
parent0c60543e066b7c2710b6eb547f48c41293d4acd6 (diff)
downloadaur-cbf7852414a9302de6c48b8bd63147ad9f1c6f09.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7f4442e97c0..9d952c543b50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_bench
pkgdesc = Syntax extension for writing in-line benchmarks in ocaml code
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_bench
arch = x86_64
@@ -11,12 +11,12 @@ pkgbase = ocaml-ppx_bench
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-ppx_inline_test>=0.13.0
- depends = ocaml-ppxlib>=0.9.0
+ depends = ocaml-ppx_inline_test>=0.14.0
+ depends = ocaml-ppxlib>=0.11.0
options = !strip
- source = ocaml-ppx_bench-1:0.13.0-2.tar.gz::https://github.com/janestreet/ppx_bench/archive/v0.13.0.tar.gz
- sha256sums = b615d8f5ad057ab461972cfa198ed17a57c6703627360750826495390e429f28
+ source = ocaml-ppx_bench-1:0.14.0-1.tar.gz::https://github.com/janestreet/ppx_bench/archive/v0.14.0.tar.gz
+ sha256sums = ee59d740e37c9b6ccf5b9df469631eee898ef37e86dbef653ce6da5cb1570cfb
pkgname = ocaml-ppx_bench
diff --git a/PKGBUILD b/PKGBUILD
index 1c1282218552..cd74d188548f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_bench'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
epoch='1'
pkgdesc='Syntax extension for writing in-line benchmarks in ocaml code'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-ppx_inline_test>=0.13.0' 'ocaml-ppxlib>=0.9.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-ppx_inline_test>=0.14.0' 'ocaml-ppxlib>=0.11.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('b615d8f5ad057ab461972cfa198ed17a57c6703627360750826495390e429f28')
+sha256sums=('ee59d740e37c9b6ccf5b9df469631eee898ef37e86dbef653ce6da5cb1570cfb')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"