summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:10:02 +0100
committerDaniel Peukert2024-01-28 00:10:02 +0100
commite2c60d4c99cfe30e998a403e2501ebb1879609d1 (patch)
treead8b7e4ab002e0a74aa8ae1bf2a40a568247f0d6
parent9ad57bb9a0be6324c140e6199176da098ec11794 (diff)
downloadaur-ocaml-ppx_cold.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b87bc6ce47b..3f569929a551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = ocaml-ppx_cold
depends = ocaml-base>=0.16.0
depends = ocaml-ppxlib>=0.28.0
options = !strip
- source = ocaml-ppx_cold-0.16.0-1.tar.gz::https://github.com/janestreet/ppx_cold/archive/v0.16.0.tar.gz
+ source = ocaml-ppx_cold-0.16.0.tar.gz::https://github.com/janestreet/ppx_cold/archive/v0.16.0.tar.gz
sha512sums = 816358747bf4e4d92b6d5fa7bc31691897f6fb88336000a5e40b86250911b2efa203f6465d77b24f0147312bfd779de49822c5ea7a2a87df49d754b8c6e30821
pkgname = ocaml-ppx_cold
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 184eabf15f6e..2d0f262c4af5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,13 @@ pkgname="ocaml-$_projectname"
pkgver='0.16.0'
pkgrel='1'
pkgdesc='Expands [@Cold] into [@inline never][@specialise never][@Local never]'
-# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
depends=('ocaml>=4.14.0' 'ocaml-base>=0.16.0' 'ocaml-ppxlib>=0.28.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('816358747bf4e4d92b6d5fa7bc31691897f6fb88336000a5e40b86250911b2efa203f6465d77b24f0147312bfd779de49822c5ea7a2a87df49d754b8c6e30821')
_sourcedirectory="$_projectname-$pkgver"
@@ -26,5 +25,5 @@ package() {
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}