summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-14 14:23:06 +0200
committerJakob Gahde2019-05-14 14:23:22 +0200
commita84706ebd6437dc9035d8cc4de31a26a0ec38f9f (patch)
tree3d898ceac892ef6ee6a2f779a8189d51a03aceff
parent1fdffd69253a0105ed2170ad50b2d80680843ada (diff)
downloadaur-a84706ebd6437dc9035d8cc4de31a26a0ec38f9f.tar.gz
ocaml-ppx_compare 1:0.12.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b333182816e..3e6629104ac0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
-# Generated by mksrcinfo v8
-# Wed Jun 27 23:53:00 UTC 2018
pkgbase = ocaml-ppx_compare
pkgdesc = Generation of comparison functions from types
- pkgver = 0.11.1
+ pkgver = 0.12.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_compare
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
- source = https://github.com/janestreet/ppx_compare/archive/v0.11.1.tar.gz
- md5sums = 3df1a90fc90d180b1f96cdd30e64145d
+ source = https://github.com/janestreet/ppx_compare/archive/v0.12.0.tar.gz
+ sha512sums = 435f805ba19fa9fc7451cf647ad17aba6da45fd03abf35cebe9a4fd07da8a90e303b2f92e7ce4855d0e84f9c7a62ef9249b714e8434053b7cbfba9b15430f27f
pkgname = ocaml-ppx_compare
diff --git a/PKGBUILD b/PKGBUILD
index 17bf8622620d..52332894d297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_compare
-pkgver=0.11.1
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Generation of comparison functions from types"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_compare"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip')
source=("https://github.com/janestreet/ppx_compare/archive/v${pkgver}.tar.gz")
-md5sums=('3df1a90fc90d180b1f96cdd30e64145d')
+sha512sums=('435f805ba19fa9fc7451cf647ad17aba6da45fd03abf35cebe9a4fd07da8a90e303b2f92e7ce4855d0e84f9c7a62ef9249b714e8434053b7cbfba9b15430f27f')
build() {
cd "${srcdir}/ppx_compare-${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_compare-${pkgver}"
- #export OPAMROOT="${srcdir}/.opam"
- #opam init -n
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}