summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-11-19 02:28:08 +0100
committerDaniel Peukert2020-11-19 02:28:08 +0100
commit0ed281b36c64b8a7d71b20005a118e7ec4b7b99e (patch)
tree4a195abfc943782ac7d23d053bca9a8d2e92b7a5
parent842854cf5fcf5daa7f4a273cf0b8bb321f34b6e8 (diff)
downloadaur-0ed281b36c64b8a7d71b20005a118e7ec4b7b99e.tar.gz
Fixed ocaml-ppx_custom_printf ppxlib compatibility
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6e2158d594e..b9a89e935c8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_custom_printf
pkgdesc = Printf-style format-strings for user-defined string conversion
pkgver = 0.14.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/janestreet/ppx_custom_printf
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = ocaml-ppx_custom_printf
depends = ocaml>=4.04.2
depends = ocaml-base>=0.14.0
depends = ocaml-ppx_sexp_conv>=0.14.0
- depends = ocaml-ppxlib>=0.11.0
+ depends = ocaml-ppxlib>=0.18.0
options = !strip
- source = ocaml-ppx_custom_printf-1:0.14.0-2.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.14.0.tar.gz
+ source = ocaml-ppx_custom_printf-1:0.14.0-3.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.14.0.tar.gz
+ source = ocaml-ppx_custom_printf-0.14.0-3-fix-ppxlib-compat.diff::https://github.com/janestreet/ppx_custom_printf/commit/d415134eb9851e0e52357046f2ed642dfc398ba3.diff
sha256sums = c527d5a578a0d6b21a38480b4360b402a27cfcc3361a4092bee16800bf8102d7
+ sha256sums = 30ad085004b3a29275b87276206ae00e194335e7d9f11f7af689e36549a95f43
pkgname = ocaml-ppx_custom_printf
diff --git a/PKGBUILD b/PKGBUILD
index 56f5ec02fa4e..4e841a1d8f68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,32 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_custom_printf'
pkgname="ocaml-$_projectname"
pkgver='0.14.0'
-pkgrel='2'
+pkgrel='3'
epoch='1'
pkgdesc='Printf-style format-strings for user-defined string conversion'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppxlib>=0.11.0')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppxlib>=0.18.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('c527d5a578a0d6b21a38480b4360b402a27cfcc3361a4092bee16800bf8102d7')
+source=(
+ "$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-fix-ppxlib-compat.diff::$url/commit/d415134eb9851e0e52357046f2ed642dfc398ba3.diff"
+)
+sha256sums=('c527d5a578a0d6b21a38480b4360b402a27cfcc3361a4092bee16800bf8102d7'
+ '30ad085004b3a29275b87276206ae00e194335e7d9f11f7af689e36549a95f43')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ # https://github.com/janestreet/ppx_custom_printf/pull/9
+ patch --forward -p1 < "$srcdir/$pkgname-$pkgver-$pkgrel-fix-ppxlib-compat.diff"
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose