summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-14 14:42:32 +0200
committerJakob Gahde2019-05-14 14:42:32 +0200
commit80e0d887777fb67a4a96447b39c0d316e1d195aa (patch)
treee7ac693bc84b9bb98da437483b0b10bd332c33dc
parentae236a38b23f41b7ecc57431df6642d0ed78fbb8 (diff)
downloadaur-80e0d887777fb67a4a96447b39c0d316e1d195aa.tar.gz
ocaml-ppx_custom_printf 1:0.12.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96b951a947ea..0c8e5b82c796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 06:40:48 UTC 2018
pkgbase = ocaml-ppx_custom_printf
pkgdesc = Printf-style format-strings for user-defined string conversion
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_custom_printf
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
depends = ocaml-ppx_sexp_conv
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_custom_printf-v0.11.0.tar.gz
- md5sums = b7cf49585319576dd77f6ddd6db95b21
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_custom_printf-v0.12.0.tar.gz
+ sha512sums = 87b61a2da62708a54f559a70d2f0bea1d6066a23a44735f5ae13a04918537054bcc971c6cd27a5f0c5f795d4679ee8fb19e9f19318b27e2ce2dfc1d30e40109e
pkgname = ocaml-ppx_custom_printf
diff --git a/PKGBUILD b/PKGBUILD
index 6e572b947c7b..66e34b415a9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_custom_printf
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Printf-style format-strings for user-defined string conversion"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_custom_printf"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_sexp_conv' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip' '!emptydirs')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_custom_printf-v${pkgver}.tar.gz")
-md5sums=('b7cf49585319576dd77f6ddd6db95b21')
+sha512sums=('87b61a2da62708a54f559a70d2f0bea1d6066a23a44735f5ae13a04918537054bcc971c6cd27a5f0c5f795d4679ee8fb19e9f19318b27e2ce2dfc1d30e40109e')
build() {
cd "${srcdir}/ppx_custom_printf-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_custom_printf-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}