summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-21 19:02:14 +0100
committerDaniel Peukert2020-03-21 19:02:14 +0100
commita8b77153c9f4dc4064b7eb679ec54b59331054ad (patch)
tree2093ba796aad0dabd099f7e523d31dd4c87f7bd2
parent80e0d887777fb67a4a96447b39c0d316e1d195aa (diff)
downloadaur-a8b77153c9f4dc4064b7eb679ec54b59331054ad.tar.gz
Added ocaml-ppx_bin_prot and dependencies
-rw-r--r--.SRCINFO24
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD49
4 files changed, 62 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c8e5b82c796..fcb3f3e22567 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = ocaml-ppx_custom_printf
pkgdesc = Printf-style format-strings for user-defined string conversion
- pkgver = 0.12.0
+ pkgver = 0.13.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_custom_printf
- arch = i686
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
- makedepends = dune
- depends = ocaml
- depends = ocaml-base
- depends = ocaml-ppx_sexp_conv
- depends = ocaml-ppxlib
+ makedepends = dune>=1.5.1
+ depends = ocaml>=4.04.2
+ depends = ocaml-base>=0.13.0
+ depends = ocaml-ppx_sexp_conv>=0.13.0
+ depends = ocaml-ppxlib>=0.9.0
options = !strip
- options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_custom_printf-v0.12.0.tar.gz
- sha512sums = 87b61a2da62708a54f559a70d2f0bea1d6066a23a44735f5ae13a04918537054bcc971c6cd27a5f0c5f795d4679ee8fb19e9f19318b27e2ce2dfc1d30e40109e
+ source = ocaml-ppx_custom_printf-0.13.0-1.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.13.0.tar.gz
+ sha256sums = cc9a7525c8fd79099afb1d4c7b8e7ad91df895246fbdf48188cf6771e734c787
pkgname = ocaml-ppx_custom_printf
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 66e34b415a9f..8927add743a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ppx_custom_printf
-pkgver=0.12.0
-pkgrel=1
-epoch=1
-pkgdesc="Printf-style format-strings for user-defined string conversion"
-arch=('i686' 'x86_64')
-url="https://github.com/janestreet/ppx_custom_printf"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppx_custom_printf'
+pkgname="ocaml-$_projectname"
+pkgver='0.13.0'
+pkgrel='1'
+epoch='1'
+pkgdesc='Printf-style format-strings for user-defined string conversion'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml' 'ocaml-base' 'ocaml-ppx_sexp_conv' 'ocaml-ppxlib')
-makedepends=('dune')
-options=('!strip' '!emptydirs')
-source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_custom_printf-v${pkgver}.tar.gz")
-sha512sums=('87b61a2da62708a54f559a70d2f0bea1d6066a23a44735f5ae13a04918537054bcc971c6cd27a5f0c5f795d4679ee8fb19e9f19318b27e2ce2dfc1d30e40109e')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-ppx_sexp_conv>=0.13.0' 'ocaml-ppxlib>=0.9.0')
+makedepends=('dune>=1.5.1')
+options=('!strip')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('cc9a7525c8fd79099afb1d4c7b8e7ad91df895246fbdf48188cf6771e734c787')
-build() {
- cd "${srcdir}/ppx_custom_printf-v${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- dune build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
package() {
- cd "${srcdir}/ppx_custom_printf-v${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
- install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}