summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 08:41:30 +0200
committerJakob Gahde2018-06-28 08:41:30 +0200
commitae236a38b23f41b7ecc57431df6642d0ed78fbb8 (patch)
tree835803954690d6137c51edbfbde98ba3964b5063
parentf37e6632e6927e7738e83283d71a324a3362dee8 (diff)
downloadaur-ae236a38b23f41b7ecc57431df6642d0ed78fbb8.tar.gz
ocaml-ppx_custom_printf 1:0.11.0-1: New version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
-rw-r--r--exedir.patch10
-rw-r--r--libdir.patch36
4 files changed, 21 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76a752d7c154..96b951a947ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,24 @@
# Generated by mksrcinfo v8
-# Tue Jun 6 12:20:07 UTC 2017
+# Thu Jun 28 06:40:48 UTC 2018
pkgbase = ocaml-ppx_custom_printf
pkgdesc = Printf-style format-strings for user-defined string conversion
- pkgver = 113.33.03
+ pkgver = 0.11.0
pkgrel = 1
+ epoch = 1
url = https://github.com/janestreet/ppx_custom_printf
arch = i686
arch = x86_64
license = Apache
- makedepends = ocaml-findlib
- makedepends = ocaml-js-build-tools
- makedepends = opam
+ makedepends = dune
depends = ocaml
- depends = ocaml-ppx_core
- depends = ocaml-ppx_driver
+ depends = ocaml-base
depends = ocaml-ppx_sexp_conv
- depends = ocaml-ppx_tools
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_custom_printf-113.33.03.tar.gz
- source = libdir.patch
- source = exedir.patch
- md5sums = 303cd723860c591491e813a43e846699
- md5sums = 7f0a951f1ac87385272ea7a6dd58762a
- md5sums = 68890ac5a31e5062096ee66bc4ff6c90
+ source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_custom_printf-v0.11.0.tar.gz
+ md5sums = b7cf49585319576dd77f6ddd6db95b21
pkgname = ocaml-ppx_custom_printf
diff --git a/PKGBUILD b/PKGBUILD
index 0c583f9d0f1a..6e572b947c7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,29 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_custom_printf
-pkgver=113.33.03
+pkgver=0.11.0
pkgrel=1
+epoch=1
pkgdesc="Printf-style format-strings for user-defined string conversion"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_custom_printf"
license=('Apache')
-depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+makedepends=('dune')
options=('!strip' '!emptydirs')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch"
- "exedir.patch")
-md5sums=('303cd723860c591491e813a43e846699'
- '7f0a951f1ac87385272ea7a6dd58762a'
- '68890ac5a31e5062096ee66bc4ff6c90')
-
-prepare() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
- patch -Np1 < "${srcdir}/libdir.patch"
- patch -Np1 < "${srcdir}/exedir.patch"
-}
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_custom_printf-v${pkgver}.tar.gz")
+md5sums=('b7cf49585319576dd77f6ddd6db95b21')
build() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/ppx_custom_printf-v${pkgver}"
- ./configure --prefix=/usr
- make
+ jbuilder build
}
package() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/ppx_custom_printf-v${pkgver}"
- make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
+ install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
diff --git a/exedir.patch b/exedir.patch
deleted file mode 100644
index f12c7ed3f631..000000000000
--- a/exedir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -aur package.pristine/install.ml package.new/install.ml
---- package.pristine/install.ml 2016-07-29 13:58:45.960287314 +0200
-+++ package.new/install.ml 2016-07-29 13:58:55.756885106 +0200
-@@ -7,5 +7,5 @@
- [ oasis_lib "ppx_custom_printf"
- ; oasis_lib "ppx_format_lifter"
- ; file "META" ~section:"lib"
-- ; oasis_exe "ppx" ~dest:"../lib/ppx_custom_printf/ppx"
-+ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_custom_printf/ppx"
- ]
diff --git a/libdir.patch b/libdir.patch
deleted file mode 100644
index 6284fcd558b0..000000000000
--- a/libdir.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -aur package.pristine/Makefile package.new/Makefile
---- package.pristine/Makefile 2016-02-06 01:55:14.650150309 +0100
-+++ package.new/Makefile 2016-02-06 01:57:56.012174364 +0100
-@@ -29,26 +29,26 @@
- ocaml -I js-utils js-utils/gen_install.ml
-
- install: $(NAME).install
-- opam-installer -i --prefix $(PREFIX) $(NAME).install
-+ opam-installer -i --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
-
- uninstall: $(NAME).install
-- opam-installer -u --prefix $(PREFIX) $(NAME).install
-+ opam-installer -u --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
-
- reinstall: $(NAME).install
-- opam-installer -u --prefix $(PREFIX) $(NAME).install &> /dev/null || true
-- opam-installer -i --prefix $(PREFIX) $(NAME).install
-+ opam-installer -u --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install &> /dev/null || true
-+ opam-installer -i --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
-
- bin.tar.gz: $(NAME).install
- rm -rf _install
- mkdir _install
-- opam-installer -i --prefix _install $(NAME).install
-+ opam-installer -i --prefix _install --libdir $(LIBDIR) $(NAME).install
- tar czf bin.tar.gz -C _install .
- rm -rf _install
-
- bin.lzo: $(NAME).install
- rm -rf _install
- mkdir _install
-- opam-installer -i --prefix _install $(NAME).install
-+ opam-installer -i --prefix _install --libdir $(LIBDIR) $(NAME).install
- cd _install && lzop -1 -P -o ../bin.lzo `find . -type f`
- rm -rf _install
-